Linuxsampler Issues on Xubuntu 18.04

You're new to the LinuxSampler world? You don't know where to start and nothing works? Here's the place to ask for help.
User avatar
cuse
Developer
Posts: 312
Joined: Wed Jan 23, 2008 10:07 pm
Location: Germany

Re: Linuxsampler Issues on Xubuntu 18.04

Post by cuse » Sat Nov 23, 2019 11:25 am

Torte wrote:Do I have to install a specific JACK-package before I build the LS-packages? Or how can I compile LS with Jack support? Sorry, I don't know much about these things. I'm just an enduser.
Yes, you need JACK's development (header) files to be installed. Which is usally available as package named "libjack-dev" on most distributions.

And like I said, when you run linuxsampler's configure script, check the summary output of linuxsampler's configure script whether it found JACK and compiles the sampler with JACK support.
Torte wrote:Also a question to qsampler GUI. ./configure says that I need the latest qt5 package. I installed the qt5-default package. It was accepted, but then I have the complete QT-Application on my computer. Which package of qt5 can I use instead?
I don't get your question. What is the problem you have with Qt?

Torte
Newbie
Posts: 9
Joined: Sat Oct 26, 2019 10:26 am

Re: Linuxsampler Issues on Xubuntu 18.04

Post by Torte » Wed Nov 27, 2019 12:03 pm

I try to explain it in other words.

To compile qsampler, I will be asked to install a Qt5 package. It seems, there are some different Qt5 packages like qt5-qmake or qt5-default, etc. I don't know which Qt5 package I really need.

Thanks and regards
Torte

User avatar
cuse
Developer
Posts: 312
Joined: Wed Jan 23, 2008 10:07 pm
Location: Germany

Re: Linuxsampler Issues on Xubuntu 18.04

Post by cuse » Wed Nov 27, 2019 4:26 pm

So you don't want to install all of the Qt5 packages, just the ones that are really required to compile QSampler.

The precise names of the (minimum required) Qt packages to install, depends on your distribution and version of your distribution. Like I suggested before, since you are on a .deb based system, building QSampler the Debian way with

Code: Select all

dpkg-buildpackage -b
avoids such issues, since it will automatically tell you if, and if yes, which precise packages are missing and which you have to install for compilation. However you can also just look at the respective debian/control file to see the build dependencies, because that's what dpkg-buildpackage reads to find the missing dependencies.

As this debian/control file of Qasmpler suggests, you should at least have qtbase5-dev, qtbase5-dev-tools, qttools5-dev and qttools5-dev-tools installed. It also mentions qtchooser, however I am not sure if that is really required. You probably just need that if you have also other versions of Qt installed at the same time (e.g. Qt4 for some older application).

Torte
Newbie
Posts: 9
Joined: Sat Oct 26, 2019 10:26 am

Re: Linuxsampler Issues on Xubuntu 18.04

Post by Torte » Thu Nov 28, 2019 1:16 am

Hey cuse!

qsampler and Linuxsampler seems to work fine now also with JACK. I just have an problem now to compile gigedit. I always get an Error while compiling:

Code: Select all

[...]
CXX      libgigedit_la-compat.lo
  CXX      libgigedit_la-gigedit.lo
In file included from mainwindow.h:60:0,
                 from gigedit.cpp:49:
dimregionedit.h:46:11: fatal error: linuxsampler/engines/LFO.h: Datei oder Verzeichnis nicht gefunden
 # include <linuxsampler/engines/LFO.h>
           ^~~~~~~~~~~~~~~~~~~~~~~~~~~~
[...]
Also I didn't find the LFO.h file on my system.

Hope you can help me out again. :)

Thank you!
Torte

User avatar
cuse
Developer
Posts: 312
Joined: Wed Jan 23, 2008 10:07 pm
Location: Germany

Re: Linuxsampler Issues on Xubuntu 18.04

Post by cuse » Thu Nov 28, 2019 10:03 am

These compile errors are due to a new LFO preview feature in Gigedit, and the error is because you are compiling latest development version of Gigedit (from svn) against the last official tarball release of LinuxSampler.

Either use both Gigedit and LinuxSampler both from svn, or use both from official tarball release.

A bit later I will address this issue such that you can also compile latest Gigedit from svn against older versions of LS.

Torte
Newbie
Posts: 9
Joined: Sat Oct 26, 2019 10:26 am

Re: Linuxsampler Issues on Xubuntu 18.04

Post by Torte » Thu Nov 28, 2019 12:06 pm

Okay, I understand! Now I compiled the gigedit tarball release and it works! Great! :D

Now I know how to compile and install LS and its equipment.

When I have any further questions about LS, I will open a new topic.

Thank You very much, cuse! :)

This topic can be closed.

Regards
Torte

Post Reply