qsampler : 'make install' failed on a Debian 10 system

You're new to the LinuxSampler world? You don't know where to start and nothing works? Here's the place to ask for help.
Post Reply
mathack
Newbie
Posts: 10
Joined: Wed Aug 15, 2012 3:43 am

qsampler : 'make install' failed on a Debian 10 system

Post by mathack » Thu Mar 26, 2020 5:51 pm

Qsampler : 'make install' failed on a debian 10 system

Hello !

My installation of qsampler went flawlessly ('./configure' and 'make'),
but 'make install' failed with an error message as follows :

root@ardi:/home/a/tar/qsampler-0.5.6# make install
lupdate: could not exec '/usr/lib/x86_64-linux-gnu/qt4/bin/lupdate': No such file or directory
make: *** [Makefile:97: translations_lupdate] Fehler 1
root@ardi:/home/a/tar/qsampler-0.5.6#

I looked up at the directory the message is referring to, and, indeed, a file named 'update' is missing.

I then tried an approach with 'build', but it again failed :

root@ardi:/home/a/tar/qsampler# dpkg-buildpackage -b
dpkg-buildpackage: Information: Quellpaket qsampler
dpkg-buildpackage: Information: Quellversion 0.6.2-42
dpkg-buildpackage: Information: Quelldistribution unstable
dpkg-buildpackage: Information: Quelle geändert durch Rui Nuno Capela <rncbc@rncbc.org>
dpkg-buildpackage: Information: Host-Architektur amd64
dpkg-source --before-build .
dpkg-checkbuilddeps: Fehler: Nicht erfüllte Bauabhängigkeiten: qttools5-dev (>= 5.1) qttools5-dev-tools (>= 5.1) liblscp-dev libgig-dev (>= 3.3.0)
dpkg-buildpackage: Warnung: Bauabhängigkeiten/-konflikte nicht erfüllt; Abbruch
dpkg-buildpackage: Warnung: (Verwenden Sie -d, um sich darüber hinwegzusetzen.)
root@ardi:/home/a/tar/qsampler#

Sorry for my console using German which I did not manage to shift to English yet. What the
message essentially means is that relevant dependencies are not fulfilled (qttools5-dev (>= 5.1) qttools5-dev-tools (>= 5.1) liblscp-dev libgig-dev (>= 3.3.0).

Any ideas/tips how to fix this ? Thank you very much in advance !

On an afterthougt, as qsampler is part of the official Debian-repos, would it work out if I simply go the way of 'apt-get install' ? Or would that damage
the half-baked installation, with libgig, linuxsampler and liblscp already working ?

By the way, as qsampler is part of the official Debian-repos : would it work out if I simply
fetched qsampler by means of 'apt-get install'?

User avatar
cuse
Developer
Posts: 333
Joined: Wed Jan 23, 2008 10:07 pm
Location: Germany

Re: qsampler : 'make install' failed on a Debian 10 system

Post by cuse » Sun Apr 12, 2020 12:07 pm

mathack wrote:
Thu Mar 26, 2020 5:51 pm
root@ardi:/home/a/tar/qsampler-0.5.6# make install
lupdate: could not exec '/usr/lib/x86_64-linux-gnu/qt4/bin/lupdate': No such file or directory
make: *** [Makefile:97: translations_lupdate] Fehler 1
Make sure Debian package qt4-linguist-tools is installed. If it is already, and since you said you are using Debian 10, be aware that there is a behaviour change regarding environment variables on Debian 10 when changing to user root. So on Debian 10 you would e.g. use

Code: Select all

su -
instead of previously just

Code: Select all

su
mathack wrote:
Thu Mar 26, 2020 5:51 pm
root@ardi:/home/a/tar/qsampler-0.5.6#

I looked up at the directory the message is referring to, and, indeed, a file named 'update' is missing.

I then tried an approach with 'build', but it again failed :

root@ardi:/home/a/tar/qsampler# dpkg-buildpackage -b
dpkg-buildpackage: Information: Quellpaket qsampler
dpkg-buildpackage: Information: Quellversion 0.6.2-42
dpkg-buildpackage: Information: Quelldistribution unstable
dpkg-buildpackage: Information: Quelle geändert durch Rui Nuno Capela <rncbc@rncbc.org>
dpkg-buildpackage: Information: Host-Architektur amd64
dpkg-source --before-build .
dpkg-checkbuilddeps: Fehler: Nicht erfüllte Bauabhängigkeiten: qttools5-dev (>= 5.1) qttools5-dev-tools (>= 5.1) liblscp-dev libgig-dev (>= 3.3.0)
dpkg-buildpackage: Warnung: Bauabhängigkeiten/-konflikte nicht erfüllt; Abbruch
dpkg-buildpackage: Warnung: (Verwenden Sie -d, um sich darüber hinwegzusetzen.)
root@ardi:/home/a/tar/qsampler#

Sorry for my console using German which I did not manage to shift to English yet. What the
message essentially means is that relevant dependencies are not fulfilled (qttools5-dev (>= 5.1) qttools5-dev-tools (>= 5.1) liblscp-dev libgig-dev (>= 3.3.0).

Any ideas/tips how to fix this ? Thank you very much in advance !
Sure! You just need to install the packages that you were told:

Code: Select all

apt install qttools5-dev qttools5-dev-tools
mathack wrote:
Thu Mar 26, 2020 5:51 pm
On an afterthougt, as qsampler is part of the official Debian-repos, would it work out if I simply go the way of 'apt-get install' ? Or would that damage
the half-baked installation, with libgig, linuxsampler and liblscp already working ?

By the way, as qsampler is part of the official Debian-repos : would it work out if I simply
fetched qsampler by means of 'apt-get install'?
I would highly recommend you to build the latest SVN (development) version of liblscp, libgig, linuxsampler, gigedit and linuxsampler from our Subversion server. For instance gigedit is also in Debian, yes, but it was compiled without liblinuxsampler and hence you would miss a large bunch of features. Not to mention that their versions are pretty old.

Post Reply