Page 1 of 1

Character with diacritics on .gig file folder

Posted: Fri Sep 09, 2011 7:02 am
by caiobarros
after almost three days trying to figure out why I could not load any instrument file I finally discovered that linuxsampler can't hadle folders with characteres with diacritics.
The error message I was getting was the following:

Code: Select all

Scheduling '/home/caio/Área de Trabalho/teste.gig' (Index=0) to be loaded in background (if not loaded yet).
Loading gig file '/home/caio/Área de Trabalho/teste.gig'...gig::Engine error: Failed to load instrument, cause: Can't open "/home/caio/Área de Trabalho/teste.gig"
My "Área de Trabalho", wich means Desktop in portuguese, was the whole problem.
Anyway, just thought that this information would be useful for some users whose system idiom uses characteres with diacritics.


Re: Character with diacritics on .gig file folder

Posted: Sat Sep 24, 2011 12:57 am
by cuse
Hmmm... did you use a frontend like QSampler or Fantasia? They should convert non-ASCII code characters (e.g. above ASCII code 127) automatically to an LSCP escape sequence.

Re: Character with diacritics on .gig file folder

Posted: Wed Oct 05, 2011 3:02 am
by caiobarros
I tried both and got the same error. The log I pasted above was taken from Qsampler.
Can this be an error in my system?