midi message ignore option ?

You're new to the LinuxSampler world? You don't know where to start and nothing works? Here's the place to ask for help.
Post Reply
JickDuck
Newbie
Posts: 17
Joined: Tue Apr 20, 2010 10:17 pm

midi message ignore option ?

Post by JickDuck » Wed Sep 21, 2011 6:10 am

Can anyone please help me on this one?

Can you choose to ignore (or filter) a certain midi cc message. Perhaps this can be done at compile time?
For example, how do you make linuxsampler not respond to "all notes off" message?
If this cannot be done, the only other option would me to rout the midi through a midi event filer.

Thank you.
Jick

Alex
Moderator
Posts: 316
Joined: Wed Jan 23, 2008 9:08 pm

Re: midi message ignore option ?

Post by Alex » Wed Sep 21, 2011 8:17 am

Jick, I think you'll need to apply a filter to any incoming midi CC you want to exclude, external of LS.


Alex.

User avatar
cuse
Developer
Posts: 349
Joined: Wed Jan 23, 2008 10:07 pm
Location: Germany

Re: midi message ignore option ?

Post by cuse » Sat Sep 24, 2011 12:10 am

There is no runtime or compile time parameter yet to ignore such MIDI events. You either need to filter it externally or touch the source code of LinuxSampler.

Have a look at src/engines/EngineBase.h, it's quite easy to modify the code there to ignore the MIDI events you dislike.

Post Reply