Two Bugs found

You're new to the LinuxSampler world? You don't know where to start and nothing works? Here's the place to ask for help.
Post Reply
count_fuzzball
User
Posts: 67
Joined: Mon Sep 01, 2008 8:53 am

Two Bugs found

Post by count_fuzzball » Sat Jul 31, 2010 6:03 pm

Just a heads up on two bugs I've found with the latest CVS of linuxsampler & co.
First one is easily reproducable. A converted soundfont (I used Extreme sample converter in WINE) that has 1 or more velocity layers that only extend to a certain range, only covering, say 0-50 midi velocity and another from say 51-90, when it's converted to gig and opened up in gigedit, it'll appear as if there's 3 velocity layers there. Clicking on the last velocity layer will cause gigedit to segfault, but if you change the velocity mapping at all, then gigedit will update itself and only show the two proper layers, with the third 'segfaulting' one disappearing. This is more cosmetic than anything else, but it'd just make gigedit look a bit nicer.

The next bug, which I think will be a bit more difficult to reproduce is, I think, a problem with the LS engine itself. I converted a few soundfonts to gig, which all appear to be properly mapped (heck, I can even open and view them in gigedit!), but on loading, linuxsampler reports 'failed to load instrument' followed by the path to the giga instrument.(Yes, I know this is very hazy, but I can provide example files if needs be!)

A feature that could be added to Gigedit (unless qgiged gets it before) would be to remove certain parts of dimensions (I.e being able to remove the mf and f layers of a 5 velocity layer piano without having to remove the whole dimension and then map it all over again).

Andrew.

count_fuzzball
User
Posts: 67
Joined: Mon Sep 01, 2008 8:53 am

Re: Two Bugs found

Post by count_fuzzball » Sun Aug 01, 2010 1:23 pm

I have a work-around of sorts for bug #2.
The files in question had % signs in the filename, so I just renamed them. IIRC, linuxsampler uses % signs to deal with spaces in giga files? So this is probably why it hiccuped.

Andrew

User avatar
cuse
Developer
Posts: 312
Joined: Wed Jan 23, 2008 10:07 pm
Location: Germany

Re: Two Bugs found

Post by cuse » Fri Aug 27, 2010 1:42 pm

Please file a bug report on bugs.linuxsampler.org so it wont get lost! Its hard for us to spot some bug reports in this forum.

Post Reply