gigedit 1.1.0 does not compile

You're new to the LinuxSampler world? You don't know where to start and nothing works? Here's the place to ask for help.

gigedit 1.1.0 does not compile

Postby CG3D » Sun Dec 03, 2017 11:09 pm

Hi,

I tried to compile gigedit 1.1.0 with GTK2 and GTK3 in Linux Mint XFCE 18.2. Both versions error out:

If I install libgtkmm-3.0-dev, libgtk-3-dev and libgtkmm-3.0-1v5, this error prevents me from compiling:
Code: Select all
regionchooser.cpp:30:25: fatal error: gdkmm/seat.h: No such file or directory


If I however install libgtkmm-2.4-dev, libgtk2.0-dev and libgtkmm-2.4-1v5, this error prevents me from compiling:
Code: Select all
wrapLabel.cc:69:27: error: ‘WORD_CHAR’ is not a member of ‘Pango::WrapMode’


Any tip to get gigedit 1.1.0 to compile would be highly appreciated...?

p.s. I tried to search the forum for 'compile gegedit' to see if anyone had already mentioned this issue but it returned an error saying:

The following words in your search query were ignored because they are too common words: compile gigedit.
You must specify at least one word to search for. Each word must consist of at least 3 characters and must not contain more than 14 characters excluding wildcards.


So, sorry if this question has been asked before. :)

Thanx in advance and greetings,

CG3D
CG3D
Newbie
 
Posts: 1
Joined: Sun Dec 03, 2017 10:44 pm

Re: gigedit 1.1.0 does not compile

Postby plusminus » Fri Dec 15, 2017 6:53 am

Working on debian stretch I too get this error:
Code: Select all
wrapLabel.cc:69:27: error: ‘WORD_CHAR’ is not a member of ‘Pango::WrapMode’
    get_layout()->set_wrap(Pango::WrapMode::WORD_CHAR);
plusminus
Newbie
 
Posts: 22
Joined: Tue Jun 21, 2016 3:32 am

Re: gigedit 1.1.0 does not compile

Postby barjac » Mon Jan 01, 2018 10:04 pm

Hit this building with gtkmm-2.4 but builds OK with gtkmm-3.0
barjac
Newbie
 
Posts: 1
Joined: Mon Jan 01, 2018 9:58 pm

Re: gigedit 1.1.0 does not compile

Postby cuse » Thu Dec 13, 2018 6:26 pm

Usually gigedit compiles with all Gtk versions 2.4 and higher. So it also compiles with Gtk 3 and even with latest Gtk 4 developer version (which is not yet released).

Please check the your compiler output whether you might have a mixed gdk/gtk/gdkmm/gtkmm/pango/pangomm version conflict. Because the thing here is that Gtk(mm) is actually split it in dozens of individual libraries, and all of them actually work only together if their versions are somewhat compatible.
User avatar
cuse
Developer
 
Posts: 302
Joined: Wed Jan 23, 2008 10:07 pm
Location: Germany


Return to Newbies & Support

Who is online

Users browsing this forum: No registered users and 3 guests

cron