Karoryfer Fashionbass

You're new to the LinuxSampler world? You don't know where to start and nothing works? Here's the place to ask for help.
Post Reply
Posts: 2
Joined: Thu Sep 28, 2017 6:23 pm

Karoryfer Fashionbass

Post by finotti » Thu Sep 28, 2017 6:34 pm

I could not make Karoryfer Fashionbass (http://www.karoryfer.com/karoryfer-samp ... ashionbass) work with LinuxSampler. It seems it does work on renoise (in Linux) and on some Windows SFZ players. I took a quick look at the SFZ file, but did not see anything "fishy". (Keep in mind, I know almost nothing about it, but tried reading about it when I could not get it to work.) So, I wonder if it is a bug with LinuxSampler.

I tried it with qsampler and Carla-Rack (both use LinuxSampler). I get no error messages, but no sound at all. Other SFZs from Karoryfer seem to work just fine.

The system (although I tried more than one) is running Debian Sid with KXStudio repositories.

Code: Select all

$ apt policy linuxsampler
  Installed: 2:2.0.0+svn3347-1kxstudio2
  Candidate: 2:2.0.0+svn3347-1kxstudio2
  Version table:
 *** 2:2.0.0+svn3347-1kxstudio2 500
        500 http://ppa.launchpad.net/kxstudio-debian/apps/ubuntu trusty/main amd64 Packages
        100 /var/lib/dpkg/status
     2:2.0.0-1kxstudio3v5 500
        500 http://ppa.launchpad.net/kxstudio-debian/gcc5/ubuntu xenial/main amd64 Packages
     2:2.0.0-1kxstudio3 500
        500 http://ppa.launchpad.net/kxstudio-debian/plugins/ubuntu trusty/main amd64 Packages
     1.0.0+svn2593-1kxstudio3 500
        500 http://ppa.launchpad.net/kxstudio-debian/plugins/ubuntu lucid/main amd64 Packages
Here is some info on the system:

Code: Select all

$ inxi -A -v3
System:    Host: debian Kernel: 4.13.0-3.slh.1-aptosid-amd64 x86_64 bits: 64 gcc: 7.2.0 Console: tty 25
           Distro: aptosid 2013-01 Ἑσπερίδες - kde-full - (201305050307)
Machine:   Device: desktop System: ASUS product: All Series serial: N/A
           Mobo: ASUSTeK model: Z87-PRO v: Rev 1.xx serial: N/A
           UEFI: American Megatrends v: 2103 date: 08/18/2014
CPU:       Quad core Intel Core i7-4771 (-HT-MCP-) arch: Haswell rev.3 cache: 8192 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 27984
           clock speeds: max: 3900 MHz 1: 3498 MHz 2: 3498 MHz 3: 3498 MHz 4: 3498 MHz 5: 3498 MHz 6: 3498 MHz
           7: 3498 MHz 8: 3498 MHz
Graphics:  Card: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller bus-ID: 00:02.0
           Display Server: X.org 1.19.3 driver: intel tty size: 133x69 Advanced Data: N/A out of X
Audio:     Card-1 Intel 8 Series/C220 Series High Definition Audio Controller bus-ID: 00:1b.0
           Card-2 Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller bus-ID: 00:03.0
           Card-3 C-Media CMI8788 [Oxygen HD Audio] driver: snd_oxygen port: d000 bus-ID: 05:04.0
           Card-4 Logitech QuickCam Communicate STX driver: USB Audio usb-ID: 003-005
           Card-5 Focusrite-Novation driver: USB Audio usb-ID: 003-002
           Sound: Advanced Linux Sound Architecture v: k4.13.0-3.slh.1-aptosid-amd64
Network:   Card: Intel Ethernet Connection I217-V driver: e1000e v: 3.2.6-k port: f080 bus-ID: 00:19.0
           IF: eth0 state: up speed: 100 Mbps duplex: full mac: e0:3f:49:a3:4c:a6
Drives:    HDD Total Size: 9257.9GB (54.0% used)
           ID-1: model: WDC_WD10EALS
           ID-2: model: WDC_WD20EARX
           ID-3: model: WDC_WD20EARX
           ID-4: model: Samsung_SSD_840
           ID-5: model: WDC_WD40EZRX
Info:      Processes: 383 Uptime: 15:04 Memory: 9264.8/15925.3MB Init: systemd runlevel: 5 Gcc sys: 7.2.0
           Client: Shell (bash 4.4.121) inxi: 2.3.37
Any help would be greatly appreciated.

Posts: 2
Joined: Thu Sep 28, 2017 6:23 pm

Re: Karoryfer Fashionbass

Post by finotti » Tue Oct 10, 2017 12:52 pm

OK, so I assume it is a bug... I will try to file a bug report.

Post Reply