Page 1 of 1

lscp.y:1386:32: error: ‘yyrhs’ was not declared in this scop

PostPosted: Thu Aug 22, 2019 4:19 pm
by ct2034
Hi. When compiling I get the error mentioned in the title.
I am using linuxsampler 2.1.1 source from tar
and libgig 4.2.0 (in case that matters)
on Ubuntu 18.04
using g++ 7.4.0.

Code: Select all
lscp.y: In function ‘bool _isRuleTerminalSymbol(int)’:
lscp.y:1386:18: error: ‘yyprhs’ was not declared in this scope
     for (int i = yyprhs[rule]; yyrhs[i] != -1; ++i)
                  ^~~~~~
lscp.y:1386:18: note: suggested alternative: ‘yyr2’
     for (int i = yyprhs[rule]; yyrhs[i] != -1; ++i)
                  ^~~~~~
                  yyr2
lscp.y:1386:32: error: ‘yyrhs’ was not declared in this scope
     for (int i = yyprhs[rule]; yyrhs[i] != -1; ++i)
                                ^~~~~
lscp.y:1386:32: note: suggested alternative: ‘yyr2’
     for (int i = yyprhs[rule]; yyrhs[i] != -1; ++i)
                                ^~~~~
                                yyr2
Makefile:448: recipe for target 'lscpparser.lo' failed

Re: lscp.y:1386:32: error: ‘yyrhs’ was not declared in this

PostPosted: Fri Aug 23, 2019 10:32 am
by cuse
Make sure Bison is installed, then force the parser to be regenerated:
Code: Select all
make parser
make