Linux Sampler Install on Fedora 35 with Pipewire

You're new to the LinuxSampler world? You don't know where to start and nothing works? Here's the place to ask for help.
Post Reply
Matt
Newbie
Posts: 1
Joined: Mon May 02, 2022 10:50 am

Linux Sampler Install on Fedora 35 with Pipewire

Post by Matt » Mon May 02, 2022 11:04 am

Hi All. I have been using LinuxSampler on Ubuntu 20.04 and it was great. I recently started using Fedora 35 which uses Pipewire by default and have been unable to install linuxsampler-2.2.0. I had a go at using the prebuild RPM for SUSE, but the system would not install it.

I then had a go at compiling it and it would not compile. It had the error in the compile saying that it needed a midi driver of either ALSA, JACK, MIDISHARE, COREIDI or MME.

I noticed that there was a conversation in the forums about this, but I did not see a solution that I could follow (My coding knowledge is not that good)
https://sourceforge.net/p/linuxsampler/ ... %40silver/

Has anyone got a suggestion on how to make LinuxSampler work with Pipewire or how to get Fedora 35 to work with LinuxSampler? Thanks for any assistance and also to those who developed this awesome software! Cheers Matt

User avatar
cuse
Developer
Posts: 365
Joined: Wed Jan 23, 2008 10:07 pm
Location: Germany

Re: Linux Sampler Install on Fedora 35 with Pipewire

Post by cuse » Fri Oct 21, 2022 5:51 pm

You need to install the required dev package of either ALSA, Pipewire or whatever you want to use then you can compile it.

Post Reply