Page 1 of 1

ah, the dreaded LSCPServer error

Posted: Sun Oct 18, 2009 5:00 pm
by davephillips

I've built and installed the latest LS & Friends on an Ubuntu Jaunty system. Alas, when I start linuxsampler I receive this error:

Starting LSCP network server ( Could not bind server socket

IIRC this is an old error. Can someone advise me on how to fix it in Jaunty ?



Re: ah, the dreaded LSCPServer error

Posted: Mon Oct 19, 2009 11:10 am
by davephillips
Never mind. For some undetermined reason the default port is in use on my system, I'm not sure what it's doing. Anyway, solved the problem, and everything seems to be working fine.

Edit : A reboot solved the issue, I can now use linuxsampler at its defaults without troubles. I still don't know what was using the port before the reboot, but sorry for the noise.

Re: ah, the dreaded LSCPServer error

Posted: Wed Oct 19, 2011 4:20 pm
by bodzio66
I just reached it what reason for this mistake is. Therefore I registered on the forum. I installed LS of a lot of times on different computers, and it was almost always well. In a few accidents I received the LSCP server error message. A moment ago I found - it "tinyproxy" was mine which port 8888 took. After lifting a blockade of the port problems ended. Well it would be if in case of this LS mistake advised about possible causes and the way of untying them. An alternative port would be useful for LS.
I am greeting everyone