Search found 312 matches

by cuse
Thu Nov 28, 2019 10:03 am
Forum: Newbies & Support
Topic: Linuxsampler Issues on Xubuntu 18.04
Replies: 15
Views: 885

Re: Linuxsampler Issues on Xubuntu 18.04

These compile errors are due to a new LFO preview feature in Gigedit, and the error is because you are compiling latest development version of Gigedit (from svn) against the last official tarball release of LinuxSampler. Either use both Gigedit and LinuxSampler both from svn, or use both from offici...
by cuse
Wed Nov 27, 2019 4:26 pm
Forum: Newbies & Support
Topic: Linuxsampler Issues on Xubuntu 18.04
Replies: 15
Views: 885

Re: Linuxsampler Issues on Xubuntu 18.04

So you don't want to install all of the Qt5 packages, just the ones that are really required to compile QSampler. The precise names of the (minimum required) Qt packages to install, depends on your distribution and version of your distribution. Like I suggested before, since you are on a .deb based ...
by cuse
Mon Nov 25, 2019 10:46 pm
Forum: Newbies & Support
Topic: Play .mid through LinuxSampler
Replies: 1
Views: 96

Re: Play .mid through LinuxSampler

You probably want to use graphical frontend application like QSampler or Fantasia to load your sound into LinuxSampler.
by cuse
Sat Nov 23, 2019 11:25 am
Forum: Newbies & Support
Topic: Linuxsampler Issues on Xubuntu 18.04
Replies: 15
Views: 885

Re: Linuxsampler Issues on Xubuntu 18.04

Do I have to install a specific JACK-package before I build the LS-packages? Or how can I compile LS with Jack support? Sorry, I don't know much about these things. I'm just an enduser. Yes, you need JACK's development (header) files to be installed. Which is usally available as package named "libj...
by cuse
Thu Nov 21, 2019 10:44 pm
Forum: Newbies & Support
Topic: Linuxsampler Issues on Xubuntu 18.04
Replies: 15
Views: 885

Re: Linuxsampler Issues on Xubuntu 18.04

You are very quick with claiming bugs. :) No seriously, most probably your linuxsampler binary was simply compiled without JACK support. Once again, check the console output when linuxsampler starts. You should see these lines: Registered MIDI Input Drivers: ALSA, JACK Registered Audio Output Driver...
by cuse
Wed Nov 06, 2019 1:22 pm
Forum: Newbies & Support
Topic: Linuxsampler Issues on Xubuntu 18.04
Replies: 15
Views: 885

Re: Linuxsampler Issues on Xubuntu 18.04

I just looked at those LADSPA plugins myself. At least the packages from Debian ("Buster" / stable) correctly contain a ladspa_descriptor() function in each one of their .so files: https://packages.debian.org/de/buster/amb-plugins So maybe just an issue with the xubuntu version of those packages you...
by cuse
Fri Nov 01, 2019 7:30 pm
Forum: Newbies & Support
Topic: Linuxsampler Issues on Xubuntu 18.04
Replies: 15
Views: 885

Re: Linuxsampler Issues on Xubuntu 18.04

Some Information from the Terminal: For Example: $ file /usr/lib/ladspa/ambisonic1.so /usr/lib/ladspa/ambisonic1.so: ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), dynamically linked, BuildID[sha1]=f9b0ef6f5e7f089c13dae691f976a9436f98d29d, stripped $ file /usr/lib/ladspa/cmt.so /usr/lib/la...
by cuse
Tue Oct 29, 2019 1:14 pm
Forum: Newbies & Support
Topic: Linuxsampler Issues on Xubuntu 18.04
Replies: 15
Views: 885

Re: Linuxsampler Issues on Xubuntu 18.04

After starting Linuxsampler I get the message: Registered instrument editors: Registered internal effect systems: LADSPA ERROR: unable to find ladspa_descriptor() in '/usr/lib/ladspa/ambisonic1.so' ERROR: unable to find ladspa_descriptor() in '/usr/lib/ladspa/ambisonic2.so' ERROR: unable to find la...
by cuse
Mon Sep 30, 2019 10:44 am
Forum: Newbies & Support
Topic: FIX-ubuntu studio compile problem (include errors)
Replies: 1
Views: 1200

Re: FIX-ubuntu studio compile problem (include errors)

You have stripped the most relevant error message from your output, but since this is a very frequently asked question, I guess you simply haven't installed flex yet: https://sourceforge.net/p/linuxsampler/mailman/message/36758576/ And since you are using a Debian based system I recommend you to com...
by cuse
Fri Aug 23, 2019 10:32 am
Forum: Newbies & Support
Topic: lscp.y:1386:32: error: ‘yyrhs’ was not declared in this scop
Replies: 1
Views: 1765

Re: lscp.y:1386:32: error: ‘yyrhs’ was not declared in this

Make sure Bison is installed, then force the parser to be regenerated:

Code: Select all

make parser
make