[Solved] Midi keyboard + Linuxsampler + SalamanderGrandPiano

You're new to the LinuxSampler world? You don't know where to start and nothing works? Here's the place to ask for help.

[Solved] Midi keyboard + Linuxsampler + SalamanderGrandPiano

Postby mayonezo » Sun Oct 07, 2012 12:33 pm

Hi guys,

I need help to get this to run in order to be able to finally get rid of my Windows partition :oops: . I got the following setup:

SL-990 pro Midikeyboard -> UA-25EX USB-audio -> my T61 laptop running Debian wheezy with SalamanderGrand sfz-files

I installed jackd from the wheezy repo through apt. For some reason qjackctl is in German, which bugs me (okay, I set up gnome to be in English but use German locales). I'd still rather have it be in English, because getting support makes it much easier that way. When I start qjackctl, this is what I get in the messages/status window:
Code: Select all
13:26:52.318 Steckfeld deaktiviert.
13:26:52.348 Statistik zurückgesetzt.
13:26:52.355 ALSA-Verbindung geändert.
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started
13:26:52.362 Schaubild der ALSA-Verbindungen geändert.


I compiled all the linuxsampler stuff from the svn repo and tried to get jack and qsampler to start to like each other. I read many forum posts and am not a stranger to the google search engine, but this I just cannot seem to be able to do on my own.

I hope you guys can help me and I'll use this thread to keep bugging you until I can play some Schubert ;)
Last edited by mayonezo on Sun Oct 14, 2012 6:23 pm, edited 1 time in total.
mayonezo
Newbie
 
Posts: 6
Joined: Sun Oct 07, 2012 12:14 pm

Re: Midi keyboard + Linuxsampler + SalamanderGrandPiano

Postby mayonezo » Sun Oct 07, 2012 1:19 pm

So I plugged my UE-25EX in and got the following message in qjackctl after pressing start:

Code: Select all
14:14:51.869 JACK is starting...
14:14:51.870 /usr/bin/jackd -n(voreinst.) -r -ddummy -r22050 -p16
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started
14:14:51.902 JACK was started with PID=6322.
no message buffer overruns
no message buffer overruns
no message buffer overruns
jackdmp 1.9.9
Copyright 2001-2005 Paul Davis and others.
Copyright 2004-2012 Grame.
jackdmp comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
JACK server starting in non-realtime mode
14:14:52.024 Could not connect to JACK server as client. - Overall operation failed. - Unable to connect to server. Please check the messages window for more info.
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started
JackTimedDriver::Process XRun = 10 usec
JackTimedDriver::Process XRun = 23 usec
JackTimedDriver::Process XRun = 23 usec
JackTimedDriver::Process XRun = 24 usec
JackTimedDriver::Process XRun = 23 usec
JackTimedDriver::Process XRun = 22 usec
JackTimedDriver::Process XRun = 21 usec
JackTimedDriver::Process XRun = 22 usec
JackTimedDriver::Process XRun = 29 usec
JackTimedDriver::Process XRun = 23 usec
JackTimedDriver::Process XRun = 24 usec
14:15:03.515 JACK is stopping...
JackTimedDriver::Process XRun = 25 usec
Jack main caught signal 15
14:15:03.550 JACK was stopped successfully.


I like how it tells me to check the messages window in the messages window :roll:
mayonezo
Newbie
 
Posts: 6
Joined: Sun Oct 07, 2012 12:14 pm

Re: Midi keyboard + Linuxsampler + SalamanderGrandPiano

Postby mayonezo » Sun Oct 07, 2012 2:06 pm

So I read on another forum that running "jackd -dalsa" in a terminal would do some good. And it did! I have no idea what it means or why it works, but now I can add the salamander instrument and add a channel which loads to 100 %. I have a feeling I could do the same with qjackctl but I have no idea how.

This is what I get in the messages in Qsampler:

Code: Select all
14:54:41.219 Client connecting...
14:54:41.224 Server is starting...
14:54:41.234 linuxsampler
14:54:41.251 Server was started with PID=7083.
lscp_client_create: cmd: connect: Connection refused
LinuxSampler 1.0.0.svn19
Copyright (C) 2003,2004 by Benno Senoner and Christian Schoenebeck
Copyright (C) 2005-2012 Christian Schoenebeck
Detected features: MMX SSE SSE2
Automatic Stacktrace: Off
Creating Sampler...OK
Registered sampler engines: 'GIG','SF2','SFZ'
Registered MIDI input drivers: ALSA,JACK
Registered audio output drivers: ALSA,JACK
Loading instrument editor plugins...OK
Registered instrument editors: 'gigedit'
Registered internal effect systems: LADSPA
Registered internal effects: 10
Starting LSCP network server (0.0.0.0:8888)...OK
14:54:44.462 Client connecting...
14:54:44.465 Client receive timeout is set to 1000 msec.
14:54:44.474 Client connected.
14:54:44.482 Sent fine tuning settings.
14:54:44.489 New session: "Untitled1".
LinuxSampler initialization completed. :-)

LSCPServer: Client connection established on socket:4.
LSCPServer: Client connection established on socket:5.
14:55:01.052 New Channel setup...
14:55:07.929 Channel 0 added.
14:55:07.992 Channel 0 Audio driver: JACK.
14:55:08.202 Channel 0 MIDI driver: ALSA.
14:55:08.205 Channel 0 MIDI port: 0.
14:55:08.207 Channel 0 MIDI channel: 0.
14:55:08.314 Channel 0 Engine: SFZ.
14:55:08.328 Channel 0 Instrument: "/home/helmar/Downloads/SalamanderGrandPianoV3_48khz24bit/SalamanderGrandPianoV3Retuned.sfz" (0).
14:55:08.330 Channel 0 MIDI map: 0.
Thread: WARNING, can't assign realtime scheduling to thread!
Starting disk thread...OK
EQ support: no
Scheduling '/home/helmar/Downloads/SalamanderGrandPianoV3_48khz24bit/SalamanderGrandPianoV3Retuned.sfz' (Index=0) to be loaded in background (if not loaded yet).
Loading sfz file '/home/helmar/Downloads/SalamanderGrandPianoV3_48khz24bit/SalamanderGrandPianoV3Retuned.sfz'...OK
Loading sfz instrument ('/home/helmar/Downloads/SalamanderGrandPianoV3_48khz24bit/SalamanderGrandPianoV3Retuned.sfz',0)...OK
Caching initial samples...OK


So i guess that worked. Now how can I actually play something? In Qsampler I connected UA-25EX MIDI 1 to Client:Linuxserver Port 0. That did nothing.
mayonezo
Newbie
 
Posts: 6
Joined: Sun Oct 07, 2012 12:14 pm

Re: Midi keyboard + Linuxsampler + SalamanderGrandPiano

Postby mayonezo » Sun Oct 07, 2012 2:33 pm

YES! I got it to work. The missing piece was connecting Linuxsampler - playback.

So now I can play my Schubert. I would be very thankful if somebody could explain to me what that error was with jack and whether I have to use the terminal to start the server or if I can change something in qjackctl to get the same behaviour.
mayonezo
Newbie
 
Posts: 6
Joined: Sun Oct 07, 2012 12:14 pm

Re: Midi keyboard + Linuxsampler + SalamanderGrandPiano

Postby varpa » Mon Oct 08, 2012 7:49 pm

I think you need to edit QJackCtl to use the correct parameters -> use the Setup panel. From your printout above QJackCtl is starting jackd like this:
/usr/bin/jackd -n(voreinst.) -r -ddummy -r22050 -p16 . You are telling it to use the "dummy" device with a 22.05 kHz sample rate, 16 periods/buffer - all in all this is completely screwed up configuration. Read this to learn about how to configure Jack with QJackCtl: http://en.flossmanuals.net/ardour/ch015 ... on-ubuntu/ (from an Ardour tutorial, but Jack section applies here). For live playing you will want to configure the latency to be below about 10msec. Above this and you will notice a lag time between hitting keys and hearing sound.
varpa
User
 
Posts: 66
Joined: Thu Dec 09, 2010 8:15 pm

Re: Midi keyboard + Linuxsampler + SalamanderGrandPiano

Postby mayonezo » Tue Oct 09, 2012 9:34 pm

Thanks for pointing me to that tutorial page!

I changed the settings (seems like the qt code is a little buggy with greying out stuff). My .jackdrc looks like this now:

Code: Select all
/usr/bin/jackd -nklavier -dalsa -dhw:1 -r48000 -p256 -n2


which is a little more sane ;)

The problem I am having seems to already exist when I start QJackCtl on its own because when I start it without starting the server, I already get these messages:

Code: Select all
22:22:50.071 Patchbay deactivated.
22:22:50.072 Statistics reset.
22:22:50.115 ALSA connection change.
22:22:50.124 D-BUS: Service is available (org.jackaudio.service aka jackdbus).
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started
22:22:50.132 ALSA connection graph change.


So does that mean that my d-bus configuration is screwed up? How can I fix that?

I read here http://ubuntuforums.org/showthread.php?t=1664915&page=3 that it could be a faulty /etc/security/limits.conf, but mine is completely untouched.

EDIT: Maybe this helps: I can only successfully create a channel in Qsampler, when I start the jack server from command line and don't give the server a name as in "/usr/bin/jackd -R -dalsa -dhw:1 -r48000 -p256 -n2" instead of "/usr/bin/jackd -R -n klavier -dalsa -dhw:1 -r48000 -p256 -n2"
mayonezo
Newbie
 
Posts: 6
Joined: Sun Oct 07, 2012 12:14 pm

Re: Midi keyboard + Linuxsampler + SalamanderGrandPiano

Postby mayonezo » Sun Oct 14, 2012 6:23 pm

Ok, so everything works fine, now that I deleted "Name" in the setup menu of qjackctl. It automatically set itself to "(default)".

I got 5.33 msec on my midi piano, so I'm extremely happy now :)
mayonezo
Newbie
 
Posts: 6
Joined: Sun Oct 07, 2012 12:14 pm


Return to Newbies & Support

Who is online

Users browsing this forum: No registered users and 2 guests