gigedit builds but linuxsampler can' tuse it

You're new to the LinuxSampler world? You don't know where to start and nothing works? Here's the place to ask for help.

Re: gigedit builds but linuxsampler can' tuse it

Postby janflorijn » Thu Aug 14, 2014 8:35 pm

Hi,

This topic starts with the issue running fantasia and loading a gig file pressing the edit button gigedit does not appear.
Here is how to solve this:
http://download.linuxsampler.org/doc/gi ... start.html

and see: Trouble with live-editing

Do not forget to follow also the instructions for gigedit, because this needs info from linuxsampler after the new compile.


Kind regards,


JanFlorijn
janflorijn
User
 
Posts: 67
Joined: Fri Jan 03, 2014 5:59 pm

Re: gigedit builds but linuxsampler can' tuse it

Postby janflorijn » Thu Aug 14, 2014 8:37 pm

The best way is to modify the file debian/rules at two places ad to ./configure: --enable-plugin-dir=/usr/lib/linuxsampler/plugins
janflorijn
User
 
Posts: 67
Joined: Fri Jan 03, 2014 5:59 pm

Re: gigedit builds but linuxsampler can' tuse it

Postby janflorijn » Thu Aug 14, 2014 9:01 pm

a other way is:
execute gedit(or a other text editor) as root from a terminal
edit the file etc/profile
ad the next 2 lines to the end:
LINUXSAMPLER_PLUGIN_DIR=/usr/lib/linuxsampler/plugins
export LINUXSAMPLER_PLUGIN_DIR
save it
in a terminal: . /etc/profile
Compile and install
1. linuxsampler and partners
2. gigedit

Kind regards,

JanFlorijn
janflorijn
User
 
Posts: 67
Joined: Fri Jan 03, 2014 5:59 pm

Re: gigedit builds but linuxsampler can' tuse it

Postby yuba » Fri Aug 15, 2014 2:12 pm

Did you install jlscp on $JRE_HOME + /lib/ext?

Yes, I did. Following the $JRE_HOME path on my system, I installed at: /usr/lib64/jvm/java/jre/lib/ext/

I've had problems in the past where programs wouldn't work because they were expecting things to be in "lib" instead of "lib64", so I also tried installing a 32 bit JRE, putting jlscp.jar in its /lib/ext/ and changing my environment variable to reflect this, but still no luck. I think I'll just have to use gigedit standalone - it's not a huge issue.

When you run make install, what are the next actions to install liblscp, to get the files in the right place?

I just did "make install" - nothing else. For me, it ends up in /usr/local/lib64/, which is where libgig is also. You can specify the install destination at the configure stage with the below if you want (see Installation Names in the INSTALL file):

Code: Select all
./configure --prefix=/path/to/dir/
yuba
Newbie
 
Posts: 6
Joined: Wed Aug 13, 2014 12:21 pm

Re: gigedit builds but linuxsampler can' tuse it

Postby janflorijn » Fri Aug 15, 2014 2:23 pm

Hi,

I should say that your install from jlscp is correct.
But, I make a conclusion:
It is not a sub-map of JDK
So you do not have JDK
And you did not compile jlscp your own, but downlaoded it.

Am I correct?

I think the best way is to have jlscp and fantasia the same release.

But I managed to reproduce your problem regarding gigedit wich does not run from fantasia.

In my case my previous last 2 posts are the solution. I saw you had a post like it, but probably modify /etc/profile is the best way and just wath you need.

Kind regards,

JanFlorijn
janflorijn
User
 
Posts: 67
Joined: Fri Jan 03, 2014 5:59 pm

Re: gigedit builds but linuxsampler can' tuse it

Postby yuba » Sat Aug 16, 2014 3:18 am

It is not a sub-map of JDK

Actually, I have a few versions in there, including openjdk and they're all linked (should've mentioned that), so putting the .jar in the location I mentioned means it's also in (among other places) /usr/lib64/jvm/jre-openjdk/lib/ext/. So yes, I did compile it myself, along with trying the latest .jar downloaded from sourceforge (they're the same version), but neither of them worked.

probably modify /etc/profile is the best way and just wath you need.

I've just tried this, but it's still not working, I'm afraid. I did the following steps:

- added the info to profile (FYI, on openSUSE, you use profile.local)
- rebooted and confirmed the path with "echo $LINUXSAMPLER_PLUGIN_DIR"
- recompiled/installed libgig, linuxsampler, gigedit in that order

Just in case, I also checked with linuxsampler running in standalone mode, rather than LV2, but that didn't work either. Anyway, like I say, it's not a huge issue so please don't spend too much time on this :-)
yuba
Newbie
 
Posts: 6
Joined: Wed Aug 13, 2014 12:21 pm

Re: gigedit builds but linuxsampler can' tuse it

Postby janflorijn » Sun Aug 24, 2014 7:56 pm

Hi,

openSUSE is nice, but I should spent more time on it. It is to difficult to get sound out of it. I suppose you have a good reason to use it.

I suppose you work with sound. In that case I prefer Ubuntu studio. One page script is enough to compile lnuxsampler and everything I need works with it.

But, as said I suppose you have a good reason to use openSUSE. So, we have to deal with it, that is fine. That is what you need.

Today I did the next thing:
I installed Ubuntu studio
I compiled r2669 from linuxsampler
Replaced at line 27 of linuxsampler/debian/rules with :
chmod a+x configure
CHOST="x86_64-pc-linux-gnu"
CXXFLAGS="-march=athlon-fx -mtune=athlon-fx"
./configure --libdir=/usr/lib --enable-plugin-dir=/usr/lib/linuxsampler/plugins --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info
touch configure-stamp


build: build-stamp

build-stamp: configure-stamp
dh_testdir

# Add here commands to compile the package.
$(MAKE)
# docbook-to-man debian/linuxsampler.sgml > linuxsampler.1

# $(MAKE)

# generate Doxygen API documentation
$(MAKE) docs

touch build-stamp

clean:
dh_testdir
dh_testroot
rm -f build-stamp configure-stamp
if [ -e Makefile.cvs ] ; then \
$(MAKE) -f Makefile.cvs; \
fi;
# Add here commands to clean up after the build process.
chmod a+x configure
CHOST="x86_64-pc-linux-gnu"
CXXFLAGS="-march=athlon-fx -mtune=athlon-fx"
./configure --libdir=/usr/lib --enable-plugin-dir=/usr/lib/linuxsampler/plugins --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info


I added the next packages: libx11-dev x11proto-core-dev docbook-xsl to my os
I did an install of everything in your case endig with make install as root.
After then i compiled r2670
I did an install of everything in your case endig with make install as root.
After then gigedit works from Fantasia.

In my case the library for gigedit in Linuxsampler is located in /usr/lib/linuxsampler/plugins/. That is the default.
If you installation has an other location I can imagion that you should use the workaround --enable-plugin-dir or something like that.

In my case this was not nessacary.

I understand that it is no great issue for you, but I like the things to work well. Who knows what else it causes.

Kind regards,

JanFlorijn
janflorijn
User
 
Posts: 67
Joined: Fri Jan 03, 2014 5:59 pm

Re: gigedit builds but linuxsampler can' tuse it

Postby janflorijn » Mon Aug 25, 2014 8:58 am

Hi,

Tomorrow I have installed Ubuntu Studio 14(with option formatting).
After than I did nothing else then:
]sudo apt-get install subversion
mkdir lssvn
cd lssvn
svn co https://svn.linuxsampler.org/svn/libgig/trunk libgig
svn co https://svn.linuxsampler.org/svn/liblscp/trunk liblscp
svn co https://svn.linuxsampler.org/svn/linuxsampler/trunk linuxsampler
svn co https://svn.linuxsampler.org/svn/qsampler/trunk qsampler
svn co https://svn.linuxsampler.org/svn/jlscp/trunk jlscp
svn co https://svn.linuxsampler.org/svn/jsampler/trunk jsampler
svn co https://svn.linuxsampler.org/svn/gigedit/trunk gigedit
sudo apt-get install g++ debhelper pkg-config automake1.1 automake1.4 automake1.9 libtool fakeroot libsndfile1-dev doxygen uuid-dev bison
sudo apt-get install intltool libgtkmm-2.4-dev xsltproc flex sqlite 3.3
sudo apt-get install ant qt4-dev-tools libjack-jackd2-dev libx11-dev x11proto-core-dev docbook-xsl
cd liblscp
chmod a+x configure
CHOST="x86_64-pc-linux-gnu"
CXXFLAGS="-march=athlon-fx -mtune=athlon-fx"
make -f Makefile.svn
./configure --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info && make
sudo make install
cd ..
cd libgig
chmod a+x configure
CHOST="x86_64-pc-linux-gnu"
CXXFLAGS="-march=athlon-fx -mtune=athlon-fx"
make -f Makefile.cvs
./configure --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info && make
sudo make install
cd ..
cd linuxsampler
chmod a+x configure
CHOST="x86_64-pc-linux-gnu"
CXXFLAGS="-march=athlon-fx -mtune=athlon-fx"
make -f Makefile.cvs
./configure --libdir=/usr/lib --enable-plugin-dir=/usr/lib/linuxsampler/plugins --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info && make
sudo make install
cd ..
cd gigedit
chmod a+x configure
CHOST="x86_64-pc-linux-gnu"
CXXFLAGS="-march=athlon-fx -mtune=athlon-fx"
make -f Makefile.cvs
./configure --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info && make
sudo make install


After then runnign Linuxsampler gives: Intrument editor 'gigedit'

Kind regards,


JanFlorijn
janflorijn
User
 
Posts: 67
Joined: Fri Jan 03, 2014 5:59 pm

Re: gigedit builds but linuxsampler can' tuse it

Postby janflorijn » Mon Aug 25, 2014 1:44 pm

Hi, running this in openSUSE works.

Running linuxsampler arterwards gives:
Registered instrument editor: 'gigedit'

In my installation of openSUSE alsa midi is not installed. Only JACK midi.

Kind regards,

JanFlorijn
janflorijn
User
 
Posts: 67
Joined: Fri Jan 03, 2014 5:59 pm

Re: gigedit builds but linuxsampler can' tuse it

Postby yuba » Wed Aug 27, 2014 11:17 am

Thanks very much for looking into this again. I'm planning to come back to it when I have more time to investigate.

I did quickly try symlinking from /usr/lib/linuxsampler/plugins/ to the directory where my libgigedit is (/usr/local/lib64/gigedit/), but this didn't work. It's quite confusing, as I also get "Loading instrument editor plugins...OK" and "Registered instrument editors: 'gigedit'", but then gigedit fails to launch. FYI, my system has ALSA MIDI, as Qtractor (my main sequencer) uses it.

Anyway, I'll try again another time and go through the info in your posts bit by bit.
yuba
Newbie
 
Posts: 6
Joined: Wed Aug 13, 2014 12:21 pm

PreviousNext

Return to Newbies & Support

Who is online

Users browsing this forum: Google [Bot] and 3 guests

cron