LinuxsamplerVSTI crashes after opening a project in Sonar 8!

You're new to the LinuxSampler world? You don't know where to start and nothing works? Here's the place to ask for help.

LinuxsamplerVSTI crashes after opening a project in Sonar 8!

Postby sonay999 » Thu Aug 13, 2009 8:40 am

Hi!

I downloaded the new windows version of Linuxsampler and it works fantasticly under Windows XP 32 bit, with a Gigabyte motherboard and a Pentium dual core processor.

It loads GIG files quickly and works as a dream really...

But then...when I opened my first saved Sonar 8 project with Linuxsampler VSTI, Sonar 8 crashed (only the Fantasia frontend survived...).

It was an error in the linuxsampler.dll file.

My Sonar is version 8.31, the latest.

It works without problems with shortcircuit and other free vsti plugins.

Can you help me?

How can I fix this problem?

Why is this bug resurfaces only after loading a saved linuxsampler project?

Because linuxsampler works perfectly when I start to build a project from the beginning...

So it must be a save/load thing...?
sonay999
Newbie
 
Posts: 12
Joined: Thu Aug 13, 2009 8:26 am

Re: LinuxsamplerVSTI crashes after opening a project in Sonar 8!

Postby cuse » Thu Aug 13, 2009 9:47 am

VSTi support is still quite new, so there are certainly still issues. VSTi is a defficile issue, because the exact behavior depends on the host application. LinuxSampler works with many VST host applications, but not with all yet. Somebody has to debug the problem with Sonar 8 to be able to fix the issue. Andreas implemented most of LinuxSampler's VST code, and he's currently on vacation. So if nobody else tries to debug the issue in the meantime, I guess it could take a while until this issue will be fixed.
User avatar
cuse
Developer
 
Posts: 291
Joined: Wed Jan 23, 2008 10:07 pm
Location: Germany

Re: LinuxsamplerVSTI crashes after opening a project in Sonar 8!

Postby sonay999 » Thu Aug 13, 2009 4:35 pm

Thanks for your reply.

I found a strange workaround...

If I save the Sonar 8 project with the linuxsampler vsti synth disabled inside Sonar, it can be loaded again and it works perfectly.

So I guess the bug surfaces when the Fantasia frontend is starting to run while the project is getting loaded into Sonar.

I don't know how much it helps...

The only problem is, if you forget to disable linuxsampler inside Sonar before saving the project, your whole work disappears...
sonay999
Newbie
 
Posts: 12
Joined: Thu Aug 13, 2009 8:26 am

Re: LinuxsamplerVSTI crashes after opening a project in Sonar 8!

Postby cuse » Fri Aug 14, 2009 8:56 am

Interesting! That might be a useful hint to solve this issue.
User avatar
cuse
Developer
 
Posts: 291
Joined: Wed Jan 23, 2008 10:07 pm
Location: Germany

Re: LinuxsamplerVSTI crashes after opening a project in Sonar 8!

Postby dicerous » Tue Aug 18, 2009 10:20 pm

Just to confirm, it crashes on sonar 7 as well, but only when you close the front end after using it in sonar's synth rack.
dicerous
Newbie
 
Posts: 3
Joined: Tue Aug 18, 2009 10:13 pm

Re: LinuxsamplerVSTI crashes after opening a project in Sonar 8!

Postby sonay999 » Fri Aug 28, 2009 6:15 pm

Any new information about this bug? Will it be fixed in a new release? How much time should it take?

I have to point out that in any case all users should be thankful for your excellent work with this project. So I'm not rushing things - I'm just curious. :oops:
sonay999
Newbie
 
Posts: 12
Joined: Thu Aug 13, 2009 8:26 am

Re: LinuxsamplerVSTI crashes after opening a project in Sonar 8!

Postby Andreas » Sat Aug 29, 2009 12:50 pm

Hi,

I have just tested the VST in Sonar 8 Producer Edition Trial (8.0.2.330), and I wasn't able to reproduce the problem. Does the crash happen everytime for you? Do I need some specific gig files, or do I need to setup LS or Sonar in some specific way?
Andreas
Developer
 
Posts: 214
Joined: Sun Feb 03, 2008 8:33 am

Re: LinuxsamplerVSTI crashes after opening a project in Sonar 8!

Postby sonay999 » Sat Aug 29, 2009 10:25 pm

Hi,

Thanks for your reply.

This is the part of the dmp file I succeded to view with windbg:

Loading unloaded module list
.........
This dump file has an exception of interest stored in it.
The stored exception information can be accessed via .ecxr.
(fe0.f78): Access violation - code c0000005 (first/second chance not available)
eax=13c60000 ebx=0710cb50 ecx=00000007 edx=7c90e514 esi=0710cb28 edi=0710cb80
eip=7c90e514 esp=0012bea4 ebp=0012beb4 iopl=0 nv up ei pl zr na pe nc
cs=001b ss=0023 ds=0023 es=0023 fs=003b gs=0000 efl=00000246
*** ERROR: Symbol file could not be found. Defaulted to export symbols for ntdll.dll -
ntdll!KiFastSystemCallRet:
7c90e514 c3 ret

What happens is this:

1.) I start a new blank project in Sonar
2.) I open the (file/edit/process/views->) "Insert" menu
3.) In the "Insert" menu I scroll down to "Soft synth", and after that "vstplugins" menu, I choose "Linuxsampler32"
4.) There is a new track after that, called "Linuxsampler"
5.) I go to "Views" menu and I select "Synth Rack": there is a window popping up after that
6.) I can activate/deactivate Linuxsampler at the left side of the Synth Rack
7.) I save the project with Linuxsampler being activated (in the Synth Rack the left side "switch" is glowing in red)
8.) When I load the saved project, Sonar crashes, generating a dmp file like the one above.

Can you reproduce the crash?
sonay999
Newbie
 
Posts: 12
Joined: Thu Aug 13, 2009 8:26 am

Re: LinuxsamplerVSTI crashes after opening a project in Sonar 8!

Postby sonay999 » Sun Aug 30, 2009 3:20 pm

I tried to reproduce the bug under Windows Vista but Linuxsampler works perfectly there. You can save and load without any problems.

So it seems it is a Windows XP (SP 3) specific problem. Some kind of missing registry?
sonay999
Newbie
 
Posts: 12
Joined: Thu Aug 13, 2009 8:26 am

Re: LinuxsamplerVSTI crashes after opening a project in Sonar 8!

Postby Andreas » Sun Aug 30, 2009 6:56 pm

sonay999 wrote:1.) I start a new blank project in Sonar
2.) I open the (file/edit/process/views->) "Insert" menu
3.) In the "Insert" menu I scroll down to "Soft synth", and after that "vstplugins" menu, I choose "Linuxsampler32"
4.) There is a new track after that, called "Linuxsampler"
5.) I go to "Views" menu and I select "Synth Rack": there is a window popping up after that
6.) I can activate/deactivate Linuxsampler at the left side of the Synth Rack
7.) I save the project with Linuxsampler being activated (in the Synth Rack the left side "switch" is glowing in red)
8.) When I load the saved project, Sonar crashes, generating a dmp file like the one above.

Can you reproduce the crash?

No, sorry, it works fine here. And I run XP SP3.
Andreas
Developer
 
Posts: 214
Joined: Sun Feb 03, 2008 8:33 am

Next

Return to Newbies & Support

Who is online

Users browsing this forum: No registered users and 2 guests

cron