Linuxsampler playback has high jitter

You're new to the LinuxSampler world? You don't know where to start and nothing works? Here's the place to ask for help.

Linuxsampler playback has high jitter

Postby voodoosound » Mon Sep 25, 2017 10:24 pm

Hi *,

I am new to linuxsampler. I posted this question in the linuxmusicians forum with little luck and hope you could give some solution.

I use Linux Mint 18 with preempt kernel on the host system and a VirtualBox VM, Mint 18 generic kernel, to run Sequencer and Sampler. I figured without IRQ to handle, prempt in VM would not be of much use.

- 16GB RAM, i7-6880HQ 8-core, Focusrite Scarlett 2i2.
- VM: 2 CPU 4GB RAM and host SSD caching!
Host and guest connected via netjack. Host is Master, guest is slave. 12 channels io + midi. 64Frames/2P.

I compiled linuxsampler from source together with qsampler. I use muse as MIDI sequencer. All connected to Jack. Hydrogen ist also running as drum machine.

I recorded my own bass guitar SFZ library, with 4 different velocities over 4 octaves, starting with B1.
Everythings working fine so far. Sequencer notes trigger the correct samples and they are played back.

Now I encountered an unpleasent behavior and I wanted to ask for some help to overcome this.

When one note is played very fast ( e.g. 32th) twice in a row (not overlapping), no sample is played is played at all.
Quickfix: 4 instrument channels in sequencer and sampler responding to different MIDI channels. The MIDI notes have the same fast onset, but are in different instrument channels with much later note off.
works...
At least the notes are played, but the playback has very high jitter/variation in exact playback time. Not only with fast notes.
I have no round robin in the SFZ file.

Hydrogen works perfectly in this setup. MIDI keyboard input works as well, but with high latency. But that doesn't bother me.

My next step is to crop the samples more accurately.

Are there any other suggestions?
Perhapes some compile time options?

BR,
Ck
voodoosound
Newbie
 
Posts: 2
Joined: Fri Sep 22, 2017 10:55 pm

Re: Linuxsampler playback has high jitter

Postby voodoosound » Sat Oct 14, 2017 11:46 am

For others who might face this situation, I found the problem.

If you record your own sample library, it is crucial that the time from the beginning of a sample to its maximum attack is constant and as short as possible for all samples.

This removes the problem that short note are not played.
The mentioned jitter was a result of variing start-to-attack-time for samples of the same note played with different velocities.

Hope this helps someone.

BR,
Ck
voodoosound
Newbie
 
Posts: 2
Joined: Fri Sep 22, 2017 10:55 pm


Return to Newbies & Support

Who is online

Users browsing this forum: No registered users and 4 guests

cron