Silent exit after long run

You're new to the LinuxSampler world? You don't know where to start and nothing works? Here's the place to ask for help.

Silent exit after long run

Postby jfinnis » Wed Nov 02, 2016 10:09 am

I'm working on a long (well, infinite) ambient piece, streaming over the net. As such, I have LinuxSampler and a few other bits connected via JACK (which is using a dummy device), streaming via DarkIce->IceCast2, all running on a virtual server.

My problem is that LinuxSampler, which is using a single instrument (the venerable Salamander piano font), is exiting after a few hours without any console output. The time varies, it can be as little as 3 hours or as long as 9. The notes are playing quite sporadically; I'm not hammering away although it's possible a couple could be triggered in quick succession. Anyone have any thoughts about what could be causing this? Or any debugging output which might help?

Thanks,
Jim
jfinnis
Newbie
 
Posts: 4
Joined: Wed Nov 02, 2016 10:02 am

Re: Silent exit after long run

Postby cuse » Wed Nov 02, 2016 7:27 pm

A back trace of the crash might help.

Follow the instructions on the following front site to compiler the and run the sampler with debugging turned on for generating such a back trace:

http://bugs.linuxsampler.org/
User avatar
cuse
Developer
 
Posts: 279
Joined: Wed Jan 23, 2008 10:07 pm
Location: Germany

Re: Silent exit after long run

Postby jfinnis » Wed Nov 02, 2016 8:20 pm

Thanks! I'll look at doing that later - it requires unpicking a fairly hairy bash script. I'll keep you posted.
jfinnis
Newbie
 
Posts: 4
Joined: Wed Nov 02, 2016 10:02 am

Re: Silent exit after long run

Postby jfinnis » Thu Nov 03, 2016 9:51 am

Running it now. Could be as simple as an oomkill - the debug version of linuxsampler was oomkilled every time it tried to load the sample bank, so it's likely the release build only just fit in memory. I'm on a bigger virtual machine now, so if this lasts a while we'll know that was the problem.

Nice system, by the way - interfacing by network is pretty hairy for beginners, but it really does give a lot of a flexibility.
jfinnis
Newbie
 
Posts: 4
Joined: Wed Nov 02, 2016 10:02 am

Re: Silent exit after long run

Postby jfinnis » Fri Nov 04, 2016 11:10 pm

And it's been running for over 24 hours quite happily. The system must have been running just inside the memory limit - frankly it's a miracle it worked at all with just a 512M allocation.

Thanks for your help! Certainly the process of debugging helped me find the problem.
jfinnis
Newbie
 
Posts: 4
Joined: Wed Nov 02, 2016 10:02 am

Re: Silent exit after long run

Postby cuse » Thu Nov 10, 2016 2:55 pm

There should probably be warning message be added in case the sampler backend runs towards low memory barriers, to avoid having to debug the sampler on low memory machines. But anyway, good that you were able to resolve this issue.
User avatar
cuse
Developer
 
Posts: 279
Joined: Wed Jan 23, 2008 10:07 pm
Location: Germany


Return to Newbies & Support

Who is online

Users browsing this forum: Google [Bot] and 1 guest

cron