David Bolton Install Guide *help*

You're new to the LinuxSampler world? You don't know where to start and nothing works? Here's the place to ask for help.

David Bolton Install Guide *help*

Postby giedosst » Fri Aug 12, 2016 7:10 pm

Hi Everyone!


Trying to intall following the David Bolton guide
(http://davidbolton.info/articles/build_linuxsampler.html

and I get to step 3 of the libgig compile and get this error:


dh_testdir
dh_testroot
dh_install -a --list-missing
dh_install: liblinuxsampler missing files: debian/tmp/usr/lib/dssi/*
dh_install: missing files, aborting
debian/rules:80: recipe for target 'binary-arch' failed
make: *** [binary-arch] Error 2
dpkg-buildpackage: error: fakeroot debian/rules binary gave error exit status 2


No .deb files appear and I can't go any further. I'm trying to install this on unbuntu studio 32 bit version. I'm new a linux and learning but this has been a real pain. Any help would be so very welcomed!


Thanks!
giedosst
Newbie
 
Posts: 1
Joined: Fri Aug 12, 2016 7:04 pm

Re: David Bolton Install Guide *help*

Postby cuse » Sun Aug 21, 2016 4:48 pm

The Debian package script assumes that you are building LinuxSampler with a DSSI plugin version of the sampler, the Debian packaging script then aborts since it cannot find the built DSSI plugin version of the sampler after compilation completed.

LinuxSampler's configure script is checking whether DSSI header (development) files are installed on your machine, if yes then a DSSI plugin version of the sampler is built along to the standalone version. You can check this is in the summary output after the configure script, i.e. marked in red below:

#####################################################################
# LinuxSampler Configuration #
#-------------------------------------------------------------------#
# Release Version: 2.0.0.svn25
# LSCP Version: 1.7
#-------------------------------------------------------------------
...
#-------------------------------------------------------------------
# Effect plugin systems for internal effects:
# LADSPA: yes
#-------------------------------------------------------------------
# Building sampler as plugin for following host standards:
# DSSI: yes, LV2: yes, VST: no, AU: no
#-------------------------------------------------------------------#
# Read './configure --help' or file 'configure.in' for details. #
#####################################################################

So simply install the DSSI header files and rebuild the Debian package:

Code: Select all
apt-get install dssi-dev

If you still get other build errors, then check the build-dependencies and install the other missing Debian packages:

Code: Select all
cat debian/control

Source: linuxsampler
Section: sound
Priority: optional
Maintainer: LinuxSampler Developers <linuxsampler-devel@lists.sourceforge.net>
Build-Depends: debhelper (>= 4.0.0), libgig-dev (>= 4.0.0),
libasound2-dev | libjack-dev, dssi-dev, lv2-dev

Standards-Version: 3.6.1

Package: linuxsampler
Section: sound
Architecture: any
...
User avatar
cuse
Developer
 
Posts: 279
Joined: Wed Jan 23, 2008 10:07 pm
Location: Germany


Return to Newbies & Support

Who is online

Users browsing this forum: No registered users and 1 guest

cron