linuxsampler svn fails to build in gentoo

You're new to the LinuxSampler world? You don't know where to start and nothing works? Here's the place to ask for help.

Re: linuxsampler svn fails to build in gentoo

Postby popoff » Wed Dec 03, 2014 6:02 am

Well I think I've solved it. I am still having a little issue with carla building but I don't think it has anything to do with linuxsampler or libgig now. I will come back tomorrow with the solution when I am sure.
popoff
Newbie
 
Posts: 12
Joined: Mon Nov 24, 2014 5:07 pm

Re: linuxsampler svn fails to build in gentoo

Postby popoff » Wed Dec 03, 2014 3:49 pm

I was taking a closer look at the ebuild for libgig and noticed something at the end of it about ld.so.conf.d: https://aur.archlinux.org/packages/li/l ... n/PKGBUILD

After the carla developer mentioned LDFLAGS I thought this must be what is causing the problem and sure enough it solves the problem.

So so sum up, do this:

Code: Select all
sudo touch /etc/ld.so.conf.d/libgig.conf
sudo echo '/usr/lib64/libgig' >> /etc/ld.so.conf.d/libgig.conf

sudo touch /etc/ld.so.conf.d/linuxsampler.conf
sudo echo '/usr/lib64/linuxsampler' >> /etc/ld.so.conf.d/linuxsampler.conf


Then, when linuxsampler fails to build the first time, do this:

Code: Select all
cd /usr/portage/distfiles/svn-src/linuxsampler/trunk/scripts
sh generate_instrument_script_parser.sh


That should make it build and there shouldn't be any problems with the references if you build other things against linuxsampler or libgig.

I'm not sure how to incorporate this in to a gentoo ebuild at the moment but that's all that needs to be done. I'm hoping to get this updated in the pro-audio overlay but for now I hope this information helps others.
popoff
Newbie
 
Posts: 12
Joined: Mon Nov 24, 2014 5:07 pm

Previous

Return to Newbies & Support

Who is online

Users browsing this forum: mmbugaj, plusminus and 1 guest