LSCP script on Mac OS X

You're new to the LinuxSampler world? You don't know where to start and nothing works? Here's the place to ask for help.

LSCP script on Mac OS X

Postby puddingstud » Thu Sep 18, 2014 2:36 pm

Hi,

I'm failing running a LSCP script on Mac. I have no error (neither in LS deamon nor in script output), but MIDI input doesn't seem to be communicating with LinuxSampler. Running with --statistics shows that nothing happens when I press a key.

Here is my script :
Code: Select all
#enable echo mode
SET ECHO 1

# load the ALSA audio driver
# (parameter CARD is optional, I use it here to select my 2nd sound card
#  you can use GET AUDIO_OUTPUT_DRIVER_PARAMETER INFO ALSA CARD to get
#  all available sound cards)
CREATE AUDIO_OUTPUT_DEVICE COREAUDIO

# load the ALSA MIDI driver
CREATE MIDI_INPUT_DEVICE COREMIDI

# connect my MIDI keyboard which has ALSA seq ID 72:0
# (see aconnect -i for the IDs of your MIDI devices
#  or use GET MIDI_INPUT_PORT_PARAMETER INFO 0 0 ALSA_SEQ_BINDINGS)
#SET MIDI_INPUT_PORT_PARAMETER 0 0 ALSA_SEQ_BINDINGS=72:0

# setup a sampler channel
ADD CHANNEL
LOAD ENGINE sfz 0
SET CHANNEL AUDIO_OUTPUT_DEVICE 0 0
SET CHANNEL MIDI_INPUT_DEVICE 0 0
LOAD INSTRUMENT '/Users/puddingstud/Sites/mysampler/studio/MellotronSamplesSfz/TB-M300B.sfz' 0 0

# finally show our channel setup (optional of course)
GET CHANNEL INFO 0

# quit connection
QUIT


Am I missing something?

Many thanks!
puddingstud
Newbie
 
Posts: 2
Joined: Thu Sep 18, 2014 2:31 pm

Re: LSCP script on Mac OS X

Postby puddingstud » Sun Sep 21, 2014 8:02 pm

Bump?
puddingstud
Newbie
 
Posts: 2
Joined: Thu Sep 18, 2014 2:31 pm


Return to Newbies & Support

Who is online

Users browsing this forum: No registered users and 2 guests

cron