cant compile libgig

You're new to the LinuxSampler world? You don't know where to start and nothing works? Here's the place to ask for help.

cant compile libgig

Postby mathack » Wed Jul 30, 2014 5:35 am

Hello !
I am trying to compile libgig on a Debian 7 64 bit-system. The compilation fails with
an error message meaning that a 'configure'-file cannot be found :

a@a:~$ cd /home/a/Arbeitsfläche/ls/libgig
a@a:~/Arbeitsfläche/ls/libgig$ dpkg-buildpackage -rfakeroot -b
dpkg-buildpackage: Quellpaket libgig
dpkg-buildpackage: Quellversion 3.3.0-6
dpkg-buildpackage: Quellen geändert durch Christian Schoenebeck <cuse@users.sourceforge.net>
dpkg-buildpackage: Host-Architektur amd64
dpkg-source --before-build libgig
fakeroot debian/rules clean
dh_testdir
dh_testroot
rm -f build-stamp
/usr/bin/make -f Makefile.cvs || true
make[1]: Entering directory `/home/a/Arbeitsfläche/ls/libgig'
Can't locate Automake/Config.pm in @INC (@INC contains: /usr/share/automake-1.11 /etc/perl /usr/local/lib/perl/5.14.2 /usr/local/share/perl/5.14.2 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.14 /usr/share/perl/5.14 /usr/local/lib/site_perl .) at /usr/bin/aclocal line 37.
BEGIN failed--compilation aborted at /usr/bin/aclocal line 37.
make[1]: *** [configure] Fehler 2
make[1]: Leaving directory `/home/a/Arbeitsfläche/ls/libgig'
chmod a+x configure
chmod: Zugriff auf „configure“ nicht möglich: Datei oder Verzeichnis nicht gefunden
make: *** [clean] Fehler 1
dpkg-buildpackage: Fehler: Fehler-Exitstatus von fakeroot debian/rules clean war 2
a@a:~/Arbeitsfläche/ls/libgig$

I then created a file named 'configure' by hand but the compilation still fails, now with the following message :

a@a:~$ cd /home/a/Arbeitsfläche/ls/libgig
a@a:~/Arbeitsfläche/ls/libgig$ dpkg-buildpackage -rfakeroot -b
dpkg-buildpackage: Quellpaket libgig
dpkg-buildpackage: Quellversion 3.3.0-6
dpkg-buildpackage: Quellen geändert durch Christian Schoenebeck <cuse@users.sourceforge.net>
dpkg-buildpackage: Host-Architektur amd64
dpkg-source --before-build libgig
fakeroot debian/rules clean
dh_testdir
dh_testroot
rm -f build-stamp
/usr/bin/make -f Makefile.cvs || true
make[1]: Entering directory `/home/a/Arbeitsfläche/ls/libgig'
Can't locate Automake/Config.pm in @INC (@INC contains: /usr/share/automake-1.11 /etc/perl /usr/local/lib/perl/5.14.2 /usr/local/share/perl/5.14.2 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.14 /usr/share/perl/5.14 /usr/local/lib/site_perl .) at /usr/bin/aclocal line 37.
BEGIN failed--compilation aborted at /usr/bin/aclocal line 37.
make[1]: *** [configure] Fehler 2
make[1]: Leaving directory `/home/a/Arbeitsfläche/ls/libgig'
chmod a+x configure
chmod: Zugriff auf „configure“ nicht möglich: Datei oder Verzeichnis nicht gefunden
make: *** [clean] Fehler 1
dpkg-buildpackage: Fehler: Fehler-Exitstatus von fakeroot debian/rules clean war 2
a@a:~/Arbeitsfläche/ls/libgig$

I tried with automake 1, 1.4 and 1.9, results were all the same.

Many thanks in advance for any help !
mathack
Newbie
 
Posts: 9
Joined: Wed Aug 15, 2012 3:43 am

Re: cant compile libgig

Postby janflorijn » Sun Aug 03, 2014 11:30 am

Hi,

Try automake1.1.

Kind regards,

Janflorijn
janflorijn
User
 
Posts: 67
Joined: Fri Jan 03, 2014 5:59 pm

Re: cant compile libgig

Postby janflorijn » Sun Aug 03, 2014 11:34 am

A complete list of required packages:
sudo apt-get install g++ debhelper pkg-config automake1.1 automake1.4 automake1.9 libtool fakeroot libsndfile1-dev doxygen uuid-dev bison
sudo apt-get install intltool libgtkmm-2.4-dev xsltproc flex sqlite 3.3
sudo apt-get install ant qt4-dev-tools libjack-jackd2-dev
janflorijn
User
 
Posts: 67
Joined: Fri Jan 03, 2014 5:59 pm

Re: cant compile libgig

Postby mathack » Fri Aug 08, 2014 5:40 am

Thank you very much. I installed everything as you suggested, now the error message reads as follows (I only copied the last 10 lines ) :

# Add here commands to compile the package.
/usr/bin/make
make[1]: Entering directory `/home/a/Arbeitsfläche/ls/libgig'
make[1]: *** Keine Targets angegeben und keine »make«-Steuerdatei gefunden. Schluss.
make[1]: Leaving directory `/home/a/Arbeitsfläche/ls/libgig'
make: *** [build-stamp] Fehler 2
dpkg-buildpackage: Fehler: Fehler-Exitstatus von debian/rules build war 2
a@a:~/Arbeitsfläche/ls/libgig$

meaning that no targets were found and no make-file either. I then uninstalled automake 1.4 and 1.9 and
tried with automake 1.1. alone, but the result was the same. I have Flex installed. Do you have any ideas ?
Many thanks in advance !
mathack
Newbie
 
Posts: 9
Joined: Wed Aug 15, 2012 3:43 am

Re: cant compile libgig

Postby janflorijn » Fri Aug 08, 2014 7:10 pm

Hi,

1. Once compiling did not work and I had installed everything I could find wich maybe could help, so very very much. This was to juch. I made a new isntall and updated linux and compiling works very well.

2. here a complete list, based on info from David Bolton:
Please execute in this order.
Please change to your architecture 32 bit/64bit and processor
You can also try without changing debian/rules, so you know if the edit of debian rules causes the problems

sudo apt-get install subversion

cd ls

svn co https://svn.linuxsampler.org/svn/libgig/trunk libgig
svn co https://svn.linuxsampler.org/svn/liblscp/trunk liblscp
svn co https://svn.linuxsampler.org/svn/linuxsampler/trunk linuxsampler
svn co https://svn.linuxsampler.org/svn/qsampler/trunk qsampler
svn co https://svn.linuxsampler.org/svn/jlscp/trunk jlscp
svn co https://svn.linuxsampler.org/svn/jsampler/trunk jsampler
svn co https://svn.linuxsampler.org/svn/gigedit/trunk gigedit

sudo apt-get install g++ debhelper pkg-config automake1.1 automake1.4 automake1.9 libtool fakeroot libsndfile1-dev doxygen uuid-dev bison(Please check if everything is installed. Execute one line a time)
sudo apt-get install intltool libgtkmm-2.4-dev xsltproc flex sqlite 3.3 (Please check if everything is installed. Execute one line a time)
sudo apt-get install ant qt4-dev-tools libjack-jackd2-dev(Please check if everything is installed. Execute one line a time)
----------------------------------
Edit text file debian/rules:(sometimes on two places!)
chmod a+x configure
CHOST="x86_64-pc-linux-gnu"
CXXFLAGS="-march=athlon-fx -mtune=athlon-fx"
./configure --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info
------------------------------------------------------
cd liblscp
dpkg-buildpackage -rfakeroot -b
cd ..
sudo dpkg -i liblscp6_0.5.7-1_i386.deb
sudo dpkg -i liblscp-dev_0.5.7-1_i386.deb
cd libgig
dpkg-buildpackage -rfakeroot -b
cd ..
dpkg-buildpackage -rfakeroot -b
sudo dpkg -i libgig6_3.3.0-6_i386.deb
sudo dpkg -i libgig-dev_3.3.0-6_i386.deb
sudo dpkg -i gigtools_3.3.0-6_i386.deb
----------------------------------
Edit text file debian/rules:(sometimes on two places!)
chmod a+x configure
CHOST="x86_64-pc-linux-gnu" CXXFLAGS="-march=athlon-fx -mtune=athlon-fx"
./configure --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info
------------------------------------------------------
cd linuxsampler
sudo dpkg-buildpackage -rfakeroot -b
cd ..
sudo dpkg -i linuxsampler_1.0.0-1_i386.deb
sudo dpkg -i liblinuxsampler-dev_1.0.0-1_i386.deb
sudo dpkg -i liblinuxsampler_1.0.0-1_i386.deb
CHOST="x86_64-pc-linux-gnu"

cd gigedit
sudo dpkg-buildpackage -rfakeroot -b
cd ..
sudo dpkg -i gigedit_0.2.0-1_i386.deb
3.
Instead of dpkg-buildpackage -rfakeroot -b you can try:
make -f makefile.cvs (sometimes svn)
./configure
make
sudo make install

and see wath happens.


Kind regards,


JanFlorijn
janflorijn
User
 
Posts: 67
Joined: Fri Jan 03, 2014 5:59 pm

Re: cant compile libgig

Postby janflorijn » Fri Aug 08, 2014 7:13 pm

Hi,

An other option is to search in the screen output to the first occurence of a error message. Mostly that gives a idea of the real cause.
One error causes the other, so what is the first cause?
Kind regards,

JanFlorijn
janflorijn
User
 
Posts: 67
Joined: Fri Jan 03, 2014 5:59 pm

Re: cant compile libgig

Postby janflorijn » Fri Aug 08, 2014 7:23 pm

Hi,
An other option:

Did you edit arbeitsflache/ls/libgig/debian/rules?

Do you run 32bit/64bit and wich processor do you have?

Can you sent the file debian rules?

Kind regards


JanFlorijn
janflorijn
User
 
Posts: 67
Joined: Fri Jan 03, 2014 5:59 pm

Re: cant compile libgig

Postby janflorijn » Fri Aug 08, 2014 7:49 pm

Hi, I should not create a configure file by hand.

Wich linux distro you use?

I work with Ubuntu Studo 14.

Please have a look at the original debian/rules and the edited:

https://drive.google.com/file/d/0B8X24I ... sp=sharing
https://drive.google.com/file/d/0B8X24I ... sp=sharing
Kind regards,

JanFlorijn
janflorijn
User
 
Posts: 67
Joined: Fri Jan 03, 2014 5:59 pm

Re: cant compile libgig

Postby janflorijn » Sat Aug 09, 2014 9:28 am

Hi,

I did a clean install ubuntu studio 14
I compiled without changing the deian/rules, I changed nothing
All the 64 bit deb files are available for download here:
https://drive.google.com/folderview?id= ... sp=sharing

The command are without changes:
---------------------
sudo apt-get install subversion
mkdir lssvn
cd lssvn
svn co https://svn.linuxsampler.org/svn/libgig/trunk libgig
svn co https://svn.linuxsampler.org/svn/liblscp/trunk liblscp
svn co https://svn.linuxsampler.org/svn/linuxsampler/trunk linuxsampler
svn co https://svn.linuxsampler.org/svn/qsampler/trunk qsampler
svn co https://svn.linuxsampler.org/svn/jlscp/trunk jlscp
svn co https://svn.linuxsampler.org/svn/jsampler/trunk jsampler
svn co https://svn.linuxsampler.org/svn/gigedit/trunk gigedit
sudo apt-get install g++ debhelper pkg-config automake1.1 automake1.4 automake1.9 libtool fakeroot libsndfile1-dev doxygen uuid-dev bison
sudo apt-get install intltool libgtkmm-2.4-dev xsltproc flex sqlite 3.3
sudo apt-get install ant qt4-dev-tools libjack-jackd2-dev
cd liblscp
dpkg-buildpackage -rfakeroot -b
cd ..
sudo dpkg -i liblscp6_0.5.7-1_amd64.deb
sudo dpkg -i liblscp-dev_0.5.7-1_amd64.deb
cd libgig
dpkg-buildpackage -rfakeroot -b
cd ..
dpkg-buildpackage -rfakeroot -b
sudo dpkg -i libgig6_3.3.0-6_amd64.deb
sudo dpkg -i libgig-dev_3.3.0-6_amd64.deb
sudo dpkg -i gigtools_3.3.0-6_amd64.deb
cd linuxsampler
sudo dpkg-buildpackage
cd ..
sudo dpkg -i linuxsampler_1.0.0-1_amd64.deb
sudo dpkg -i liblinuxsampler-dev_1.0.0-1_amd64.deb
sudo dpkg -i liblinuxsampler_1.0.0-1_amd64.deb
cd gigedit
sudo dpkg-buildpackage
cd ..
sudo dpkg -i gigedit_0.2.0-1_amd64.deb
------------------------------------
Kind regards,
JanFlorijn
janflorijn
User
 
Posts: 67
Joined: Fri Jan 03, 2014 5:59 pm

Re: cant compile libgig

Postby mathack » Sun Aug 10, 2014 10:59 am

Thank you very much !

With your recent suggestion: it fails again with a message saying
that a file named 'configure' cant be found :

make[1]: *** [configure] Fehler 255
make[1]: Leaving directory `/home/a/Arbeitsfläche/lssvn/liblscp'
chmod a+x ./configure
chmod: Zugriff auf „./configure“ nicht möglich: Datei oder Verzeichnis nicht gefunden
make: *** [clean] Fehler 1
dpkg-buildpackage: Fehler: Fehler-Exitstatus von fakeroot debian/rules clean war 2
a@a:~/Arbeitsfläche/lssvn/liblscp$

As you can see from the screenshot, no 'configure'-file has come over from svn : Image (I hope it worked out with posting the screenshot, if not : I swear there is no file named 'configure' around !)
mathack
Newbie
 
Posts: 9
Joined: Wed Aug 15, 2012 3:43 am

Next

Return to Newbies & Support

Who is online

Users browsing this forum: No registered users and 1 guest