cant compile libgig

You're new to the LinuxSampler world? You don't know where to start and nothing works? Here's the place to ask for help.

Re: cant compile libgig

Postby janflorijn » Wed Jan 28, 2015 7:35 am

Good morning,

The processor I will look at.

Did you run the commands before make install?

You must run make install as root. That is the meaning of sudo. Did you run as root?

When you run as root and you still receive the error as listed below, search this error in line 1 on on Google
or run the command in line 2 in a terminal
or look at the internet adress in line 3.

Code: Select all
underquoted definition of AC_GTKGLEXTMM_SUPPORTS_MULTIHEAD
/usr/share/aclocal/gtkglextmm-1.2.m4:225: run info '(automake)Extending aclocal'
/usr/share/aclocal/gtkglextmm-1.2.m4:225: or see http://sources.redhat.com/automake/auto ... ng-aclocal



Kind regards,


JanFlorijn
janflorijn
User
 
Posts: 67
Joined: Fri Jan 03, 2014 5:59 pm

Re: cant compile libgig

Postby janflorijn » Wed Jan 28, 2015 9:57 am

Good morning,

For the processor you can try the following options:
1. CXXFLAGS="-march=native -mtune=native"
2. Search at https://wiki.gentoo.org/wiki/Safe_CFLAG ... ic_options
3. CXXFLAGS="-march=generic -mtune=generic"

Kind regards,

JanFlorijn
janflorijn
User
 
Posts: 67
Joined: Fri Jan 03, 2014 5:59 pm

Re: cant compile libgig

Postby mathack » Fri Jan 30, 2015 6:47 am

Thank you !

Now, this is going to be a bit troublesome.....

of course I did run the command as root.

I tweaked the file : /usr/share/aclocal/gtkglextmm-1.2.m4 as was suggested in the bug reports you referred to (by replacing line 225 - AC_DEFUN(AC_GTKGLEXTMM_SUPPORTS_MULTIHEAD, by : AC_DEFUN(AC_GTKGLEXTMM_SUPPORTS_MULTIHEAD, but
without any effect, that is,the command 'make' still produces the same error as before.

In your last but one post you made three suggestions. If you look at the third line where you refer to a link : do you know the complete link,
because, in its present shape, with the dots in between, it does not lead to the target.

Many thanks in advance !
mathack
Newbie
 
Posts: 9
Joined: Wed Aug 15, 2012 3:43 am

Re: cant compile libgig

Postby janflorijn » Fri Jan 30, 2015 7:45 am

Hi,

/usr/share/aclocal/gtkglextmm-1.2.m4:225: or see http://sources.redhat.com/automake/auto ... ng-aclocal

The link is output from yoour action in a terminal. Indeed it will not work with the dots. I advice you to search manual at http://sources.redhat.com/automake

Kind regards,

JanFlorijn
janflorijn
User
 
Posts: 67
Joined: Fri Jan 03, 2014 5:59 pm

Previous

Return to Newbies & Support

Who is online

Users browsing this forum: No registered users and 1 guest

cron