Vir-midi does not work after compiling and installing LS

You're new to the LinuxSampler world? You don't know where to start and nothing works? Here's the place to ask for help.

Vir-midi does not work after compiling and installing LS

Postby janflorijn » Wed Jun 25, 2014 12:25 pm

Hi all,

I succeeded tot compile Linuxsampler and the libs and tools for 32-bit.

There is one problem:

After installing this snd vir-midi does not work.

asjmidid -e does work.

Linuxsampler starts but I can not connect virtually midi ports in jack simply because they do not exist.

This is an totally new fact.

I have installed the nessecary libs for jack and libasound.

It does not work.

Whoe has an idea?


Kind regards,


JanFlorijn
janflorijn
User
 
Posts: 67
Joined: Fri Jan 03, 2014 5:59 pm

Re: Vir-midi does not work after compiling and installing LS

Postby varpa » Sat Jun 28, 2014 9:09 pm

On my system, AVLinux 6.0.3, virmidi must be started by loading the virmidi kernel module with command: sudo modprobe snd-virmidi However, its possible to have this module loaded automatically at start up. You can check if this module is running with command:
$ lsmod | grep virmidi
snd_virmidi 1911 0
...
(you should see that snd_virmidi kernel module is running)
varpa
User
 
Posts: 66
Joined: Thu Dec 09, 2010 8:15 pm

Re: Vir-midi does not work after compiling and installing LS

Postby janflorijn » Sun Aug 03, 2014 3:19 pm

Hi,

I suppose you type: a2jmidid -e and you run 'linuxsampler'

I use in Linux qjackctl. In qjackctl I connect the alsa midi ports of my sequenser with the ports of a2j.

Kind regards,

JanFlorijn
janflorijn
User
 
Posts: 67
Joined: Fri Jan 03, 2014 5:59 pm


Return to Newbies & Support

Who is online

Users browsing this forum: No registered users and 1 guest

cron