[solved] configure file can't find Jack or ALSA [debian]

You're new to the LinuxSampler world? You don't know where to start and nothing works? Here's the place to ask for help.

[solved] configure file can't find Jack or ALSA [debian]

Postby camobrite » Sat Mar 14, 2009 11:19 pm

Hello, I've been trying to get a working build of linuxsampler on my debian system. I'm using debian testing on a pentium 3 dell.

Using the latest binary debian packages from linuxsampler I was unable to get gigedit to work (it would crash whenever I tried to save a file!), so I decided to build the .deb packages by hand from the latest code on the cvs repository. First I purged all of the old linuxsampler packages from my system (including both libgig packages, rabble rabble), then I built and installed the libgig and liblscp using dpkg-buildpackage -b with the default config settings and dpkg -i, which worked fine.

When I tried to install linuxsampler though, there were problems. First, dpkg-buildpackage complained that I needed a parser program, like yacc or bison, to build the binary. So I used apt-get to install bison and tried again. Now it is complaining that I don't have alsa or jack installed on my system! Since I have both alsa and jack, this is very confusing.Anyone else having this problem or have a suggestion? Here's the last bit of the output from dpkg-buildpackage, that claims I don't have ALSA midi or Jack:

Code: Select all
checking uuid/uuid.h usability... yes
checking uuid/uuid.h presence... yes
checking for uuid/uuid.h... yes
checking for library containing uuid_generate... -luuid
checking alsa/asoundlib.h usability... no
checking alsa/asoundlib.h presence... no
checking for alsa/asoundlib.h... no
checking Alsa version... 1.1.1
checking for JACK... no
checking for i486-linux-gnu-artsc-config... no
checking for artsc-config... no
checking for ARTS artsc - version >= 0.9.5... no
*** The artsc-config script installed by ARTS could not be found
*** If ARTS was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the ARTS_CONFIG environment variable to the
*** full path to artsc-config.
checking for ASIO headerfile: ./ASIOSDK2/common/asio.h ....no
checking MidiShare.h usability... no
checking MidiShare.h presence... no
checking for MidiShare.h... no
checking CoreMIDI/CoreMIDI.h usability... no
checking CoreMIDI/CoreMIDI.h presence... no
checking for CoreMIDI/CoreMIDI.h... no
checking CoreAudio/CoreAudio.h usability... no
checking CoreAudio/CoreAudio.h presence... no
checking for CoreAudio/CoreAudio.h... no
checking for mmsystem.h... (cached) no
checking dssi.h usability... no
checking dssi.h presence... no
checking for dssi.h... no
checking for LV2... no
checking lv2.h usability... no
checking lv2.h presence... no
checking for lv2.h... no
checking AudioUnit/AudioUnit.h usability... no
checking AudioUnit/AudioUnit.h presence... no
checking for AudioUnit/AudioUnit.h... no
No supported MIDI input system found!
Sorry, LinuxSampler only supports the following MIDI drivers at the moment:
ALSA, JACK, MIDIShare, CoreMIDI, MME.
If you think you have one of those available on your system, make sure you
also have the respective development (header) files installed.
make: *** [clean] Error 255
dpkg-buildpackage: failure: fakeroot debian/rules clean gave error exit status 2
Last edited by camobrite on Mon Mar 23, 2009 3:25 am, edited 1 time in total.
camobrite
Newbie
 
Posts: 20
Joined: Sat Mar 14, 2009 12:28 am

Re: configure file can't find Jack or ALSA [debian]

Postby grishata » Sun Mar 15, 2009 2:36 am

You need to install the development packages - libasound2-dev, libjack-dev.
grishata
Developer
 
Posts: 138
Joined: Thu Jan 24, 2008 7:21 pm
Location: Bulgaria

Re: configure file can't find Jack or ALSA [debian]

Postby camobrite » Sun Mar 15, 2009 6:20 pm

That worked! Good looking out, grishata. Although I though dpkg-buildpackage was supposed to automatically tell you if there's unmet dependencies?

-B
camobrite
Newbie
 
Posts: 20
Joined: Sat Mar 14, 2009 12:28 am

Re: [solved] configure file can't find Jack or ALSA [debian]

Postby alias65536 » Mon Aug 29, 2016 6:40 am

2016 August installing on Kubuntu 16.04.1, for use with Ardour, don't install libjack-dev if you have the latest version of jack;
use instead:
Code: Select all
sudo apt-get install libjack-jackd2-dev

The old version will break a few things, and ./configure for linuxsampler-2.0.0 still shows that JACK MIDI will work after installing this package.
alias65536
Newbie
 
Posts: 1
Joined: Mon Aug 29, 2016 6:35 am


Return to Newbies & Support

Who is online

Users browsing this forum: No registered users and 1 guest

cron