[SOLVED] New Channel MIDI/Input Type Dialog

You're new to the LinuxSampler world? You don't know where to start and nothing works? Here's the place to ask for help.

[SOLVED] New Channel MIDI/Input Type Dialog

Postby Alanpasi » Mon Feb 11, 2008 5:33 pm

Hi
Now I can't choose ALSA to the "New Channel MIDI/Input Type Dialog" (show only JACK) from QSampler , so it is not available to Rosegarden (Manage MIDI Devices).
Image
What am I doing wrong?

Kernel: 2.6.22-14-rt
ALSA: 1.0.16
jackd: 0.109.2
LinuxSampler: 0.5.1.2cvs
libgig: 3.2.1
liblscp: 0.5.5.3
Qsampler: 0.2.1.5
Rosegarden: 1.7.0-svn
KDE: 3.5.8
Qt: 3.3.7
USB Uno MIDI Interface
Last edited by Alanpasi on Tue Feb 26, 2008 11:32 pm, edited 1 time in total.
Alanpasi
Newbie
 
Posts: 9
Joined: Wed Jan 23, 2008 11:25 pm

Re: New Channel MIDI/Input Type Dialog

Postby Alex » Mon Feb 11, 2008 5:41 pm

Alan, i faced the same challenge, and after some enquiries found a 'link' file that works well here.

http://home.gna.org/a2jmidid

It basically links alsa to jack ported programmes.

hope this is of some use to you.

Alex.
Alex
Moderator
 
Posts: 316
Joined: Wed Jan 23, 2008 9:08 pm

Re: New Channel MIDI/Input Type Dialog

Postby Alanpasi » Mon Feb 11, 2008 6:29 pm

Alex
It seems to be a QSampler/liblscp issue.
When I manually create a MIDI ALSA Device in QSampler Device dialog, it is showed in Rosegarden.

Image
Image
Image

I gave a try to a2jmidid:
JACK MIDI <-> ALSA sequencer MIDI bridge
Copyright 2006,2007 Dmitry S. Baikov
Copyright 2007,2008 Nedko Arnaudov
Started.
port created: rosegarden (playback): record in
port created: rosegarden (capture): sync out
port created: rosegarden (capture): external controller
port created: rosegarden (playback): external controller
port created: rosegarden (capture): out 1 MIDI external device
port created: LinuxSampler (playback): Port 0
port created: rosegarden (capture): out 2 MIDI software device

Thanks for the advice.
Alanpasi
Newbie
 
Posts: 9
Joined: Wed Jan 23, 2008 11:25 pm

Re: [SOLVED] New Channel MIDI/Input Type Dialog

Postby Alanpasi » Tue Feb 26, 2008 11:31 pm

Hi
Great!!!
Fixed by Schoenebeck in last CVS update.

Thank you,
Alanpasi
Alanpasi
Newbie
 
Posts: 9
Joined: Wed Jan 23, 2008 11:25 pm



Return to Newbies & Support

Who is online

Users browsing this forum: Bing [Bot] and 1 guest