FL Studio plugin bridge compatibility - feature request?

You name it!

FL Studio plugin bridge compatibility - feature request?

Postby Bennett » Sat Feb 02, 2013 8:22 pm

Dear Linuxsampler team:

I use FL Studio to do the majority of my sequencing. Recent versions of FL Studio (I believe 10.x) has a feature to bridge plugins into their own memory space. This is hugely helpful for RAM hungry plugins such as BFD. LS works great in FL, but when I attempt to bridge it, it crashes.

This is not a priority item, or even needed for LS functionality, but it would be great if LS could be compatible with bridging in FL Studio.

I do not know about the technical details of bridging a VST, however, Frederic (a.k.a. reflex) at FL Studios has kindly offered to answer any questions. He can be contacted at: frederic AT flstudio DOT com
Bennett
Newbie
 
Posts: 22
Joined: Thu Feb 26, 2009 4:18 pm

Re: FL Studio plugin bridge compatibility - feature request?

Postby Andreas » Sun Feb 03, 2013 9:42 am

When I saw the other FL Studio post in the forum a while ago, I tried the FL Studio 10 demo (v10.0.9), and yes, I get a crash when I load the 64 bit linuxsampler vst. The 32 bit version loads OK. FL Studio seems to be a 32 bit program, so I guess the bridge (ilbridge.exe) is a solution to use 64 bit vst plugins from FL Studio.

I debugged the issue a bit, and I found that if I revert the increase of number of programs from 128 to 16384 that were made in LS 2012-09-22, the crash disappears. You can maybe verify this by testing the linuxsampler_20120919_setup.exe version? It it works, we should discuss with your FL contact if there is a max number of programs in ilbridge, and if it's ilbrigde or LS that should be changed.

Then I was sidetracked when I noticed that only some of the instruments in the gig I was testing with worked in FL Studio, the others gave no sound at all. Very strange. I haven't looked any further into this yet.
edit: The problem with silent instruments is solved by turning on "Use fixed size buffers" in the plugin wrapper "processing" settings in FL Studio.
Andreas
Developer
 
Posts: 214
Joined: Sun Feb 03, 2008 8:33 am

Re: FL Studio plugin bridge compatibility - feature request?

Postby Bennett » Sun Feb 03, 2013 4:14 pm

Andreas wrote:FL Studio seems to be a 32 bit program, so I guess the bridge (ilbridge.exe) is a solution to use 64 bit vst plugins from FL Studio.


Indeed you are right that ilbridge provides a solution for 64bit VST. It is also very useful for 32bit VST to overcome the 2G RAM limitation. I am using the 32bit LS in WinXP.

Andreas wrote:I debugged the issue a bit, and I found that if I revert the increase of number of programs from 128 to 16384 that were made in LS 2012-09-22, the crash disappears. You can maybe verify this by testing the linuxsampler_20120919_setup.exe version?


Success! The 20120919 version bridges without crashing.

Andreas wrote:The problem with silent instruments is solved by turning on "Use fixed size buffers" in the plugin wrapper "processing" settings in FL Studio.


Thank you for the advice, I haven't run into the silent instrument problem, but if I do I will use the fixed sized buffer option.
Bennett
Newbie
 
Posts: 22
Joined: Thu Feb 26, 2009 4:18 pm

Re: FL Studio plugin bridge compatibility - feature request?

Postby Bennett » Mon Feb 04, 2013 6:20 pm

The devs at Image-Line informed me that the ilbridge supports a maximum of 2048 programs. Although they also stated that this shouldn't crash the bridge process.
Bennett
Newbie
 
Posts: 22
Joined: Thu Feb 26, 2009 4:18 pm

Re: FL Studio plugin bridge compatibility - feature request?

Postby Andreas » Fri Feb 08, 2013 8:46 am

As a test, I compiled a minimal VST instrument (the vstxsynth example from vstsdk 2.4) with a single change: kNumPrograms=3000.

The plugin doesn't work with ilbridge. ilbridge does seem to crash: "Plugin has closed. VstXSynth (bridged)". When compiled with the default value, kNumPrograms=128, the plugin works.

I've sent a mail to the FL Studio contact.
Andreas
Developer
 
Posts: 214
Joined: Sun Feb 03, 2008 8:33 am

Re: FL Studio plugin bridge compatibility - feature request?

Postby Bennett » Fri Feb 08, 2013 7:14 pm

Andreas wrote:As a test, I compiled a minimal VST instrument (the vstxsynth example from vstsdk 2.4) with a single change: kNumPrograms=3000.

The plugin doesn't work with ilbridge. ilbridge does seem to crash: "Plugin has closed. VstXSynth (bridged)". When compiled with the default value, kNumPrograms=128, the plugin works.

I've sent a mail to the FL Studio contact.


Many Thanks Andreas. I really appreciate your continuing efforts.
Bennett
Newbie
 
Posts: 22
Joined: Thu Feb 26, 2009 4:18 pm

Re: FL Studio plugin bridge compatibility - feature request?

Postby Bennett » Tue Feb 19, 2013 5:32 pm

Andreas wrote:I've sent a mail to the FL Studio contact.


Any updates on your discussions with the FL Studio devs?
Bennett
Newbie
 
Posts: 22
Joined: Thu Feb 26, 2009 4:18 pm

Re: FL Studio plugin bridge compatibility - feature request?

Postby Andreas » Wed Feb 20, 2013 7:34 pm

Bennett wrote:Any updates on your discussions with the FL Studio devs?

The test plugin I made confirmed that the current ilbridge couldn't handle more than 2048 programs in a VST. But it also confirmed that this bug was already solved in the next version of ilbridge, so I guess we were content with that.

The developer also told me that the linuxsampler installer once had messed up his Windows, by removing every entry in the PATH environment variable. I found a hint that NSIS (the system we use to create the linuxsampler installer) installers could do that if the value of PATH is long. The solution is to rebuild the makensis program with a special option. I did that, so from linuxsampler_20130208_setup.exe and onwards that problem is solved.
Andreas
Developer
 
Posts: 214
Joined: Sun Feb 03, 2008 8:33 am

Re: FL Studio plugin bridge compatibility - feature request?

Postby Bennett » Tue Apr 30, 2013 2:59 pm

Andreas wrote:The test plugin I made confirmed that the current ilbridge couldn't handle more than 2048 programs in a VST. But it also confirmed that this bug was already solved in the next version of ilbridge, so I guess we were content with that.

The developer also told me that the linuxsampler installer once had messed up his Windows, by removing every entry in the PATH environment variable. I found a hint that NSIS (the system we use to create the linuxsampler installer) installers could do that if the value of PATH is long. The solution is to rebuild the makensis program with a special option. I did that, so from linuxsampler_20130208_setup.exe and onwards that problem is solved.


For those still interested, LS VST is now fully bridge compatible with FL Studio 11 (recently released) and works very well.
Bennett
Newbie
 
Posts: 22
Joined: Thu Feb 26, 2009 4:18 pm


Return to General LinuxSampler Discussion

Who is online

Users browsing this forum: No registered users and 1 guest

cron