default max-voices and max-streams

You name it!

default max-voices and max-streams

Postby MisterBark » Tue Jun 09, 2009 3:45 am

Hi,

For complicated reasons I can't compile linuxsampler with source.
(it can't find libgig but it's there and my PKG_CONFIG_PATH is correct)

Someone needs I start to compose very quickly for his film, so I don't have time to spend 3 days and nights to understand the problem.
That's why I'm just able to use the deb packages.

It's precompiled and there's only one version:
a binary with default values --enable-max-voices=64 and --enable-max-streams=90 !

Honestly, it's even not enough to play a simple piano gig library !
If you use the pedal to play a very simple cue, it's up to 64 in 3 or 4 seconds only !

Imagine if you need to run a whole orchestra...
Personally, I run LinuxSampler on a very big PC and need probably more than 500 voices of polyphony to be sure no sample will be cut.

So my question is :

1) why choosing a so small limit by default ?
is it so heavy to specify a max of 640 voices if you use only 64 ?

2) could you plan to do a "large" version of the binaries, as a deb package ?
It could be really useful for those who don't have time to compile if an error occurred.

By the way, MANY THANKS to everyone for making this program for Linux, and so, giving to free people another choice than using so bad softs on mac or windows.

PS: "Network cluster support" -> OMG ! what a wonderful idea ! I can't imagine the powerful workstation we could make with 15 or 20 computers ! just an amazing orchestra running 20 different solos violins instead of 1 ensemble bank ... :)
This feature could make the difference between win/mac and the Linux choice. Just enough to persuade misinformed people to come to Linux.
Sure, most people won't use it, but the most famous ones will. Here is a good opportunity to make known LS and Linux.
User avatar
MisterBark
Newbie
 
Posts: 6
Joined: Tue Feb 05, 2008 7:23 pm
Location: Montreal, Canada

Re: default max-voices and max-streams

Postby cuse » Tue Jun 09, 2009 1:46 pm

The reason why we use a so low limit is that most new users use a very old box to test LinuxSampler the first time. There are still even a lot of people who are using a box without SSE support. That's why we e.g. include a separate binary with the new Windows installer of LS, so those people can use it as well. Imagine what would happen if we released it with a high voice / streams limit setting. Many new users aren't even aware about voice stealing concepts etc., so they would report things like LS having a worse audio quality, even though its just the limit setting being to high for their slow machines.

Fortunately the voice / streams limit can now be adjusted at runtime with the current CVS version and upcoming release. Which I hope answers your second question as well.

Anyway, I'm sure your libgig problem is solveable. As you are using a Debian based system. Have you read the Debian compilation howto of LS? I definitely recommend you to go the .deb build way, instead of installing LS and co directly to your system. Most problems (similar to yours) were caused by users installing libgig etc under wrong directories (e.g. /usr/local) or still having an old version of libgig or gigedit installed, e.g. at a different place.
User avatar
cuse
Developer
 
Posts: 291
Joined: Wed Jan 23, 2008 10:07 pm
Location: Germany

Re: default max-voices and max-streams

Postby MisterBark » Tue Jun 09, 2009 6:22 pm

Hi ! :)

Thanks for your answer !

Ok, I understand your choice for these limits :(

cuse wrote:Fortunately the voice / streams limit can now be adjusted at runtime with the current CVS version and upcoming release. Which I hope answers your second question as well.


Oh really ? :) great news !
But, if I could compile LS, there would be no problem... So I have to wait for the compiled release :(
-> how the values will be adjusted ? a configuration window in Qsampler ? :)

cuse wrote:Anyway, I'm sure your libgig problem is solveable. (...) Most problems (similar to yours) were caused by users installing libgig etc under wrong directories (e.g. /usr/local) or still having an old version of libgig or gigedit installed, e.g. at a different place.


Sure it' solvable. But it need probably 3 days more to success. But I don't have them.
I'm running on a Ubuntu 8.10 (non studio).
Yes, that's right, I saw a problem with /usr/local

cuse wrote:As you are using a Debian based system. Have you read the Debian compilation howto of LS? I definitely recommend you to go the .deb build way, instead of installing LS and co directly to your system.


EDIT:
Oh ! ok, the debian way, by editing the "rules" file.
I tried but it's exactly the same than when I compile it manually (normal, it does the same things) (a compilation error in lscpserver.lo)

THANKS :D
User avatar
MisterBark
Newbie
 
Posts: 6
Joined: Tue Feb 05, 2008 7:23 pm
Location: Montreal, Canada

Re: default max-voices and max-streams

Postby cuse » Wed Jun 10, 2009 8:47 am

Yes, you can change the voice and streams limit in the settings dialog of qsampler and jsampler. And they can be stored in the the session files of course.

A compilation error in lscpserver.lo? That doesn't sound like a libgig problem. Can you post the relevant error messages?
User avatar
cuse
Developer
 
Posts: 291
Joined: Wed Jan 23, 2008 10:07 pm
Location: Germany

Re: default max-voices and max-streams

Postby MisterBark » Wed Jun 10, 2009 5:50 pm

Hi !

It's nice of you to propose me your help in the original problem ;)

Ok, so, the first problem is in libgig compilation :

from libgig-3.2.1.tar.bz2
./configure --prefix=/usr => OK

but an error occurs in the make :
Code: Select all
root@a:/home/mrbark/src/libgig-3.2.1# make
make  all-recursive
make[1]: Entering directory `/home/mrbark/src/libgig-3.2.1'
Making all in doc
make[2]: Entering directory `/home/mrbark/src/libgig-3.2.1/doc'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/home/mrbark/src/libgig-3.2.1/doc'
Making all in man
make[2]: Entering directory `/home/mrbark/src/libgig-3.2.1/man'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/home/mrbark/src/libgig-3.2.1/man'
Making all in src
make[2]: Entering directory `/home/mrbark/src/libgig-3.2.1/src'
Making all in testcases
make[3]: Entering directory `/home/mrbark/src/libgig-3.2.1/src/testcases'
make[3]: Nothing to be done for `all'.
make[3]: Leaving directory `/home/mrbark/src/libgig-3.2.1/src/testcases'
make[3]: Entering directory `/home/mrbark/src/libgig-3.2.1/src'
if /bin/bash ../libtool --mode=compile g++ -DHAVE_CONFIG_H -I. -I. -I..    -pedantic -Wreturn-type -O2 -pipe -mcpu=prescott -mtune=prescott -march=prescott -mfpmath=sse -msse -msse2 -msse3 -mmmx -MT RIFF.lo -MD -MP -MF ".deps/RIFF.Tpo" -c -o RIFF.lo RIFF.cpp; \
   then mv -f ".deps/RIFF.Tpo" ".deps/RIFF.Plo"; else rm -f ".deps/RIFF.Tpo"; exit 1; fi
mkdir .libs
 g++ -DHAVE_CONFIG_H -I. -I. -I.. -pedantic -Wreturn-type -O2 -pipe -mcpu=prescott -mtune=prescott -march=prescott -mfpmath=sse -msse -msse2 -msse3 -mmmx -MT RIFF.lo -MD -MP -MF .deps/RIFF.Tpo -c RIFF.cpp  -fPIC -DPIC -o .libs/RIFF.o
`-mcpu=' is deprecated. Use `-mtune=' or '-march=' instead.
RIFF.cpp: In member function 'void RIFF::Chunk::ReadHeader(long unsigned int)':
RIFF.cpp:102: warning: ignoring return value of 'ssize_t read(int, void*, size_t)', declared with attribute warn_unused_result
RIFF.cpp:103: warning: ignoring return value of 'ssize_t read(int, void*, size_t)', declared with attribute warn_unused_result
RIFF.cpp: In member function 'void RIFF::Chunk::WriteHeader(long unsigned int)':
RIFF.cpp:154: warning: ignoring return value of 'ssize_t write(int, const void*, size_t)', declared with attribute warn_unused_result
RIFF.cpp:155: warning: ignoring return value of 'ssize_t write(int, const void*, size_t)', declared with attribute warn_unused_result
RIFF.cpp: In member function 'virtual long unsigned int RIFF::Chunk::WriteChunk(long unsigned int, long unsigned int)':
RIFF.cpp:891: warning: ignoring return value of 'ssize_t write(int, const void*, size_t)', declared with attribute warn_unused_result
RIFF.cpp: In member function 'void RIFF::List::MoveSubChunk(RIFF::Chunk*, RIFF::Chunk*)':
RIFF.cpp:1172: error: no matching function for call to 'find(std::_List_iterator<RIFF::Chunk*>, std::_List_iterator<RIFF::Chunk*>, RIFF::Chunk*&)'
RIFF.cpp: In member function 'void RIFF::List::ReadHeader(long unsigned int)':
RIFF.cpp:1229: warning: ignoring return value of 'ssize_t read(int, void*, size_t)', declared with attribute warn_unused_result
RIFF.cpp: In member function 'void RIFF::List::WriteHeader(long unsigned int)':
RIFF.cpp:1253: warning: ignoring return value of 'ssize_t write(int, const void*, size_t)', declared with attribute warn_unused_result
make[3]: *** [RIFF.lo] Error 1
make[3]: Leaving directory `/home/mrbark/src/libgig-3.2.1/src'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/mrbark/src/libgig-3.2.1/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/mrbark/src/libgig-3.2.1'
make: *** [all] Error 2


Then, the only solution for now is to install libgig from the .deb precompiled package or with the ubuntu synaptic manager.
And then, other packages can't find libgig if I compile them from the source.
So if I start to install libgig with .deb, I must continue to install everything by this way, and so, I can't specify voices and streams (and I got unoptimized binaries)

I always preferred the source compilation way, it's really more powerful, but I don't understand this error and google doesn't help a lot...
THANKS ! :D

PS: if I clear my CFLAGS, it's the same :
Code: Select all
make[3]: Entering directory `/home/mrbark/src/libgig-3.2.1/src'
if /bin/bash ../libtool --mode=compile g++ -DHAVE_CONFIG_H -I. -I. -I..    -pedantic -Wreturn-type  -MT RIFF.lo -MD -MP -MF ".deps/RIFF.Tpo" -c -o RIFF.lo RIFF.cpp; \
   then mv -f ".deps/RIFF.Tpo" ".deps/RIFF.Plo"; else rm -f ".deps/RIFF.Tpo"; exit 1; fi
mkdir .libs
 g++ -DHAVE_CONFIG_H -I. -I. -I.. -pedantic -Wreturn-type -MT RIFF.lo -MD -MP -MF .deps/RIFF.Tpo -c RIFF.cpp  -fPIC -DPIC -o .libs/RIFF.o
RIFF.cpp: In member function 'void RIFF::List::MoveSubChunk(RIFF::Chunk*, RIFF::Chunk*)':
RIFF.cpp:1172: error: no matching function for call to 'find(std::_List_iterator<RIFF::Chunk*>, std::_List_iterator<RIFF::Chunk*>, RIFF::Chunk*&)'
make[3]: *** [RIFF.lo] Error 1
User avatar
MisterBark
Newbie
 
Posts: 6
Joined: Tue Feb 05, 2008 7:23 pm
Location: Montreal, Canada

Re: default max-voices and max-streams

Postby cuse » Wed Jun 10, 2009 7:49 pm

You are using the last tarball release of libgig, as I can see it. Use the CVS version of libgig! Use everything from CVS (libgig, linuxsampler, gigedit, ... ) ! There were so many issue we fixed since the last release. And the current CVS version of all libs and apps are now already release-worthy stable, so there is absolutely no point in using the old versions!

Let me know in case that doesn't solve your problem!
User avatar
cuse
Developer
 
Posts: 291
Joined: Wed Jan 23, 2008 10:07 pm
Location: Germany

Re: default max-voices and max-streams

Postby MisterBark » Wed Jun 10, 2009 9:27 pm

Hi !

Thanks a lot. I retried to install everything from cvs.
It's alright (even LS with voices and streams), UNTIL the last one to install : qsampler ! :(

I got the following error on build :

Code: Select all
root@a:/home/mrbark/src/qsampler# dpkg-buildpackage -rfakeroot -b
dpkg-buildpackage: warning: using a gain-root-command while being root
dpkg-buildpackage: use CFLAGS from environment: -O2 -pipe -mcpu=prescott -mtune=prescott -march=prescott -mfpmath=sse -msse -msse2 -msse3 -mmmx
dpkg-buildpackage: set CPPFLAGS to default value:
dpkg-buildpackage: set LDFLAGS to default value: -Wl,-Bsymbolic-functions
dpkg-buildpackage: set FFLAGS to default value: -g -O2
dpkg-buildpackage: use CXXFLAGS from environment: -O2 -pipe -mcpu=prescott -mtune=prescott -march=prescott -mfpmath=sse -msse -msse2 -msse3 -mmmx
dpkg-buildpackage: source package qsampler
dpkg-buildpackage: source version 0.2.1-1
dpkg-buildpackage: source changed by Rui Nuno Capela <rncbc@users.sourceforge.net>
dpkg-buildpackage: host architecture i386
 fakeroot debian/rules clean
dh_testdir
dh_testroot
rm -f build-stamp
# Add here commands to clean up after the build process.
/usr/bin/make -f Makefile.cvs
make[1]: Entering directory `/home/mrbark/src/qsampler'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/home/mrbark/src/qsampler'
chmod a+x configure
/usr/bin/make distclean
make[1]: Entering directory `/home/mrbark/src/qsampler'
make[1]: *** No rule to make target `distclean'.  Stop.
make[1]: Leaving directory `/home/mrbark/src/qsampler'
make: [clean] Error 2 (ignored)
cp -f /usr/share/misc/config.sub config.sub
cp -f /usr/share/misc/config.guess config.guess
dh_clean
   rm -f debian/qsampler.substvars
   rm -f debian/qsampler.*.debhelper
   rm -f debian/qsampler.debhelper.log
   rm -rf debian/qsampler/
   rm -f debian/files
   find .  \( \( -type f -a \
           \( -name '#*#' -o -name '.*~' -o -name '*~' -o -name DEADJOE \
       -o -name '*.orig' -o -name '*.rej' -o -name '*.bak' \
       -o -name '.*.orig' -o -name .*.rej -o -name '.SUMS' \
       -o -name TAGS -o \( -path '*/.deps/*' -a -name '*.P' \) \
      \) -exec rm -f {} \; \) -o \
      \( -type d -a -name autom4te.cache -prune -exec rm -rf {} \; \) \)
 debian/rules build
dh_testdir
# Add here commands to compile the package.
/usr/bin/make
make[1]: Entering directory `/home/mrbark/src/qsampler'
make[2]: Entering directory `/home/mrbark/src/qsampler'
g++ -c -pipe -O2 -Wall -W -D_REENTRANT -DQT_NO_DEBUG -DQT_GUI_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/share/qt4/mkspecs/linux-g++ -I. -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtGui -I/usr/include/qt4/QtGui -I/usr/include/qt4 -Isrc -I/usr/include/qt4 -I/usr/local/include -I/usr/include -I/usr/include/qt4 -I.moc -I.ui -o .obj/qsamplerOptions.o src/qsamplerOptions.cpp
src/qsamplerOptions.cpp: In member function ‘int QSampler::Options::getEffectiveMaxVoices()’:
src/qsamplerOptions.cpp:461: error: ‘::lscp_get_voices’ has not been declared
src/qsamplerOptions.cpp: In member function ‘void QSampler::Options::setMaxVoices(int)’:
src/qsamplerOptions.cpp:474: error: ‘::lscp_set_voices’ has not been declared
src/qsamplerOptions.cpp: In member function ‘int QSampler::Options::getEffectiveMaxStreams()’:
src/qsamplerOptions.cpp:502: error: ‘::lscp_get_streams’ has not been declared
src/qsamplerOptions.cpp: In member function ‘void QSampler::Options::setMaxStreams(int)’:
src/qsamplerOptions.cpp:515: error: ‘::lscp_set_streams’ has not been declared
make[2]: *** [.obj/qsamplerOptions.o] Error 1
make[2]: Leaving directory `/home/mrbark/src/qsampler'
make[1]: *** [qsampler] Error 2
make[1]: Leaving directory `/home/mrbark/src/qsampler'
make: *** [build-stamp] Error 2
dpkg-buildpackage: failure: debian/rules build gave error exit status 2


Then, I tried to use the qsampler version of my synaptic package manager. I can install it but when I select a gig file with the "open" button (after selecting gig engine) qsampler simply kills !
In a terminal it looks like that :

Code: Select all
mrbark@a:~$ qsampler
Warning: no locale found: /usr/share/locale/qsampler_en_CA.qm
### -> AT THIS POINT, QSAMPLER IS RUNNING, NO PROBLEM
### THEN I ADD A CHANNEL, SELECT "GIG ENGINE", NO PROBLEM, AND HERE, I JUST SELECT A GIG FILE...
*** glibc detected *** qsampler: double free or corruption (!prev): 0x08d240b0 ***
======= Backtrace: =========
/lib/tls/i686/cmov/libc.so.6[0xb71a3454]
/lib/tls/i686/cmov/libc.so.6(cfree+0x96)[0xb71a54b6]
/usr/lib/libstdc++.so.6(_ZdlPv+0x21)[0xb73810b1]
/usr/lib/libgig.so.6(_ZN4RIFF4FileD0Ev+0x71)[0xb7f0d48f]
qsampler[0x8065e8e]
qsampler[0x808a809]
qsampler[0x80b1870]
/usr/lib/libQtCore.so.4(_ZN11QMetaObject8activateEP7QObjectiiPPv+0x200)[0xb7511a60]
/usr/lib/libQtCore.so.4(_ZN11QMetaObject8activateEP7QObjectPKS_iPPv+0x52)[0xb75127e2]
/usr/lib/libQtGui.so.4(_ZN9QComboBox9activatedERK7QString+0x43)[0xb7a78e93]
/usr/lib/libQtGui.so.4[0xb7a7b1fd]
/usr/lib/libQtGui.so.4[0xb7a7d445]
/usr/lib/libQtGui.so.4(_ZN9QComboBox11qt_metacallEN11QMetaObject4CallEiPPv+0x1ee)[0xb7a82a4e]
/usr/lib/libQtCore.so.4(_ZN11QMetaObject8activateEP7QObjectiiPPv+0x200)[0xb7511a60]
/usr/lib/libQtCore.so.4(_ZN11QMetaObject8activateEP7QObjectPKS_iPPv+0x52)[0xb75127e2]
/usr/lib/libQtGui.so.4[0xb7d0dfa3]
/usr/lib/libQtGui.so.4[0xb7a7ac79]
/usr/lib/libQtCore.so.4(_ZN23QCoreApplicationPrivate29sendThroughObjectEventFiltersEP7QObjectP6QEvent+0x9a)[0xb74fc04a]
/usr/lib/libQtGui.so.4(_ZN19QApplicationPrivate13notify_helperEP7QObjectP6QEvent+0x9a)[0xb771e8ca]
/usr/lib/libQtGui.so.4(_ZN12QApplication6notifyEP7QObjectP6QEvent+0xa71)[0xb77270e1]
/usr/lib/libQtCore.so.4(_ZN16QCoreApplication14notifyInternalEP7QObjectP6QEvent+0xb1)[0xb74fce61]
/usr/lib/libQtGui.so.4(_ZN19QApplicationPrivate14sendMouseEventEP7QWidgetP11QMouseEventS1_S1_PS1_R8QPointerIS0_E+0xde)[0xb772636e]
/usr/lib/libQtGui.so.4[0xb77908de]
/usr/lib/libQtGui.so.4(_ZN12QApplication15x11ProcessEventEP7_XEvent+0x1625)[0xb778f9e5]
/usr/lib/libQtGui.so.4[0xb77b97aa]
/usr/lib/libglib-2.0.so.0(g_main_context_dispatch+0x1e8)[0xb703b718]
/usr/lib/libglib-2.0.so.0[0xb703edc3]
/usr/lib/libglib-2.0.so.0(g_main_context_iteration+0x71)[0xb703ef81]
/usr/lib/libQtCore.so.4(_ZN20QEventDispatcherGlib13processEventsE6QFlagsIN10QEventLoop17ProcessEventsFlagEE+0x58)[0xb7527478]
/usr/lib/libQtGui.so.4[0xb77b8ea5]
/usr/lib/libQtCore.so.4(_ZN10QEventLoop13processEventsE6QFlagsINS_17ProcessEventsFlagEE+0x4a)[0xb74fb52a]
/usr/lib/libQtCore.so.4(_ZN10QEventLoop4execE6QFlagsINS_17ProcessEventsFlagEE+0xea)[0xb74fb6ea]
/usr/lib/libQtGui.so.4(_ZN7QDialog4execEv+0xe7)[0xb7b8b987]
qsampler[0x8063317]
qsampler[0x80a188c]
qsampler[0x80b1cad]
/usr/lib/libQtCore.so.4(_ZN11QMetaObject8activateEP7QObjectiiPPv+0x200)[0xb7511a60]
/usr/lib/libQtCore.so.4(_ZN11QMetaObject8activateEP7QObjectPKS_iiPPv+0x60)[0xb7511e60]
/usr/lib/libQtGui.so.4(_ZN7QAction9triggeredEb+0x51)[0xb77185f1]
/usr/lib/libQtGui.so.4(_ZN7QAction8activateENS_11ActionEventE+0xaf)[0xb7718f5f]
/usr/lib/libQtGui.so.4[0xb7af6564]
/usr/lib/libQtGui.so.4(_ZN5QMenu17mouseReleaseEventEP11QMouseEvent+0x132)[0xb7af6ff2]
/usr/lib/libQtGui.so.4(_ZN7QWidget5eventEP6QEvent+0x9a2)[0xb7776962]
/usr/lib/libQtGui.so.4(_ZN5QMenu5eventEP6QEvent+0xc9)[0xb7af92e9]
/usr/lib/libQtGui.so.4(_ZN19QApplicationPrivate13notify_helperEP7QObjectP6QEvent+0xbc)[0xb771e8ec]
/usr/lib/libQtGui.so.4(_ZN12QApplication6notifyEP7QObjectP6QEvent+0xa71)[0xb77270e1]
/usr/lib/libQtCore.so.4(_ZN16QCoreApplication14notifyInternalEP7QObjectP6QEvent+0xb1)[0xb74fce61]
/usr/lib/libQtGui.so.4(_ZN19QApplicationPrivate14sendMouseEventEP7QWidgetP11QMouseEventS1_S1_PS1_R8QPointerIS0_E+0xde)[0xb772636e]
/usr/lib/libQtGui.so.4[0xb77908de]
/usr/lib/libQtGui.so.4(_ZN12QApplication15x11ProcessEventEP7_XEvent+0x1625)[0xb778f9e5]
/usr/lib/libQtGui.so.4[0xb77b97aa]
/usr/lib/libglib-2.0.so.0(g_main_context_dispatch+0x1e8)[0xb703b718]
/usr/lib/libglib-2.0.so.0[0xb703edc3]
/usr/lib/libglib-2.0.so.0(g_main_context_iteration+0x71)[0xb703ef81]
/usr/lib/libQtCore.so.4(_ZN20QEventDispatcherGlib13processEventsE6QFlagsIN10QEventLoop17ProcessEventsFlagEE+0x58)[0xb7527478]
/usr/lib/libQtGui.so.4[0xb77b8ea5]
/usr/lib/libQtCore.so.4(_ZN10QEventLoop13processEventsE6QFlagsINS_17ProcessEventsFlagEE+0x4a)[0xb74fb52a]
/usr/lib/libQtCore.so.4(_ZN10QEventLoop4execE6QFlagsINS_17ProcessEventsFlagEE+0xea)[0xb74fb6ea]
/usr/lib/libQtGui.so.4(_ZN5QMenu4execERK6QPointP7QAction+0x81)[0xb7af90b1]
qsampler[0x80a4440]
/usr/lib/libQtGui.so.4(_ZN7QWidget5eventEP6QEvent+0xcad)[0xb7776c6d]
/usr/lib/libQtGui.so.4(_ZN11QMainWindow5eventEP6QEvent+0x77)[0xb7aca517]
/usr/lib/libQtGui.so.4(_ZN19QApplicationPrivate13notify_helperEP7QObjectP6QEvent+0xbc)[0xb771e8ec]
======= Memory map: ========
08048000-080cd000 r-xp 00000000 08:11 488294     /usr/bin/qsampler
080cd000-080ce000 rw-p 00085000 08:11 488294     /usr/bin/qsampler
089c5000-08da4000 rw-p 089c5000 00:00 0          [heap]
b5600000-b5621000 rw-p b5600000 00:00 0
b5621000-b5700000 ---p b5621000 00:00 0
b5716000-b5717000 ---p b5716000 00:00 0
b5717000-b5f17000 rw-p b5717000 00:00 0
b5f17000-b5f2c000 r-xp 00000000 08:11 568334     /lib/tls/i686/cmov/libnsl-2.8.90.so
b5f2c000-b5f2d000 r--p 00014000 08:11 568334     /lib/tls/i686/cmov/libnsl-2.8.90.so
b5f2d000-b5f2e000 rw-p 00015000 08:11 568334     /lib/tls/i686/cmov/libnsl-2.8.90.so
b5f2e000-b5f30000 rw-p b5f2e000 00:00 0
b5f30000-b5f37000 r-xp 00000000 08:11 568330     /lib/tls/i686/cmov/libnss_compat-2.8.90.so
b5f37000-b5f38000 r--p 00006000 08:11 568330     /lib/tls/i686/cmov/libnss_compat-2.8.90.so
b5f38000-b5f39000 rw-p 00007000 08:11 568330     /lib/tls/i686/cmov/libnss_compat-2.8.90.so
b5f50000-b5fd9000 r--p 00000000 08:11 137240     /usr/share/fonts/truetype/ttf-dejavu/DejaVuSans-Bold.ttf
b5fd9000-b602b000 r-xp 00000000 08:11 296773     /usr/lib/libtiff.so.4.2.1
b602b000-b602d000 r--p 00052000 08:11 296773     /usr/lib/libtiff.so.4.2.1
b602d000-b602e000 rw-p 00054000 08:11 296773     /usr/lib/libtiff.so.4.2.1
b6039000-b6043000 r-xp 00000000 08:11 568342     /lib/tls/i686/cmov/libnss_files-2.8.90.so
b6043000-b6044000 r--p 00009000 08:11 568342     /lib/tls/i686/cmov/libnss_files-2.8.90.so
b6044000-b6045000 rw-p 0000a000 08:11 568342     /lib/tls/i686/cmov/libnss_files-2.8.90.so
b6045000-b6074000 r-xp 00000000 08:11 411298     /usr/lib/liblcms.so.1.0.16
b6074000-b6075000 ---p 0002f000 08:11 411298     /usr/lib/liblcms.so.1.0.16
b6075000-b6076000 r--p 0002f000 08:11 411298     /usr/lib/liblcms.so.1.0.16
b6076000-b6077000 rw-p 00030000 08:11 411298     /usr/lib/liblcms.so.1.0.16
b6077000-b607a000 rw-p b6077000 00:00 0
b607a000-b60e5000 r-xp 00000000 08:11 114133     /usr/lib/libmng.so.1.1.0.9
b60e5000-b60e8000 rw-p 0006a000 08:11 114133     /usr/lib/libmng.so.1.1.0.9
b60ee000-b60f7000 r-xp 00000000 08:11 568329     /lib/tls/i686/cmov/libnss_nis-2.8.90.so
b60f7000-b60f8000 r--p 00008000 08:11 568329     /lib/tls/i686/cmov/libnss_nis-2.8.90.so
b60f8000-b60f9000 rw-p 00009000 08:11 568329     /lib/tls/i686/cmov/libnss_nis-2.8.90.so
b60f9000-b60fd000 r-xp 00000000 08:11 454270     /usr/lib/qt4/plugins/imageformats/libqtiff.so
b60fd000-b60fe000 r--p 00003000 08:11 454270     /usr/lib/qt4/plugins/imageformats/libqtiff.so
b60fe000-b60ff000 rw-p 00004000 08:11 454270     /usr/lib/qt4/plugins/imageformats/libqtiff.so
b60ff000-b6104000 r-xp 00000000 08:11 454267     /usr/lib/qt4/plugins/imageformats/libqmng.so
b6104000-b6105000 r--p 00004000 08:11 454267     /usr/lib/qt4/plugins/imageformats/libqmng.so
b6105000-b6106000 rw-p 00005000 08:11 454267     /usr/lib/qt4/plugins/imageformats/libqmng.so
b6106000-b610e000 r-xp 00000000 08:11 454268     /usr/lib/qt4/plugins/imageformats/libqjpeg.so
b610e000-b610f000 r--p 00008000 08:11 454268     /usr/lib/qt4/plugins/imageformats/libqjpeg.so
b610f000-b6110000 rw-p 00009000 08:11 454268     /usr/lib/qt4/plugins/imageformats/libqjpeg.so
b6110000-b6116000 r-xp 00000000 08:11 454269     /usr/lib/qt4/plugins/imageformats/libqico.so
b6116000-b6117000 r--p 00005000 08:11 454269     /usr/lib/qt4/plugins/imageformats/libqico.so
b6117000-b6118000 rw-p 00006000 08:11 454269     /usr/lib/qt4/plugins/imageformats/libqico.so
b6118000-b611d000 r-xp 00000000 08:11 454272     /usr/lib/qt4/plugins/imageformats/libqgif.so
b611d000-b611e000 r--p 00004000 08:11 454272     /usr/lib/qt4/plugins/imageformats/libqgif.so
b611e000-b611f000 rw-p 00005000 08:11 454272     /usr/lib/qt4/plugins/imageformats/libqgif.so
b611f000-b6123000 r-xp 00000000 08:11 155382     /usr/lib/kde4/plugins/imageformats/kimg_xview.so
b6123000-b6124000 r--p 00003000 08:11 155382     /usr/lib/kde4/plugins/imageformats/kimg_xview.so
b6124000-b6125000 rw-p 00004000 08:11 155382     /usr/lib/kde4/plugins/imageformats/kimg_xviewAborted


By the way, I prefere using the cvs qsampler version, but build error...
User avatar
MisterBark
Newbie
 
Posts: 6
Joined: Tue Feb 05, 2008 7:23 pm
Location: Montreal, Canada

Re: default max-voices and max-streams

Postby cuse » Wed Jun 10, 2009 9:47 pm

Do you have a mixed installation of liblscp? It seems like you had recent liblscp header files installed (CVS version of liblscp), but qsampler is yet trying to link against an ancient version of liblscp. Make sure all old versions of liblscp are removed from your system and install the latest CVS version of liblscp, then it should work.

Btw, check out JSampler! As of today it's more powerful than qsampler and you don't have to compile anything. Java is now also in Debian, so it shouldn't be an issue.
User avatar
cuse
Developer
 
Posts: 291
Joined: Wed Jan 23, 2008 10:07 pm
Location: Germany

Re: default max-voices and max-streams

Postby MisterBark » Thu Jun 11, 2009 6:53 am

Thanks a lot for your help ! :D

So, here is my way to install by the most simple way and powerful enough :

1 - install everything from the synaptic package manager
(libgig, libgig-dev, liblscp, liblscp-dev, qsampler, with bison and the last version of libqt4-dev)

2 - install libgig from cvs, with every optimizations (by overwriting the other one)

3 - install linuxsampler from cvs, with optimizations and configure options

AND VOILA ! :)
By this way, Qsampler can control linuxsampler without killing himself... It works perfectly :)
After all, where do we need really optimized binaries ? libgig and linuxsampler in my opinion

I tried JSampler just now. But what I expected happened : it's so heavy !!! I always hated java for that reason.
Using a heavy program as a simple front-end is really stupid...
Qsampler is perfect for me, I don't need any tinsel :)

So now, I just need to recompile my kernel because there's only 3.5GB detected, and it's not enough to load the gig files ! :?

THANKS AGAIN, you helped me a lot ! :D
User avatar
MisterBark
Newbie
 
Posts: 6
Joined: Tue Feb 05, 2008 7:23 pm
Location: Montreal, Canada

Re: default max-voices and max-streams

Postby cuse » Thu Jun 11, 2009 8:14 am

I appreciate that it finally works for you. Yeah, the only binaries that really need optimization settings for GCC are libgig and linuxsampler. The frontends won't do heavy computational tasks and gigedit wouldn't either.
User avatar
cuse
Developer
 
Posts: 291
Joined: Wed Jan 23, 2008 10:07 pm
Location: Germany


Return to General LinuxSampler Discussion

Who is online

Users browsing this forum: No registered users and 4 guests

cron