Clicky noise woes

You name it!

Clicky noise woes

Postby suedwestlicht » Wed Jun 25, 2014 3:22 pm

Hi all,

my notebook computer with 16 GB of RAM, a Core i5 CPU and a SSD works fine with Xubuntu 12.04 and several more modern kernels. I have no JACK-problems. Every 10-30 seconds the beginning of a note played with Linuxsampler (sfz-engine) has a nasty click noise. I tried:

- Qtractor and linuxsampler-lv2
- Rosegarden and linuxsampler-dssi
- Rosegarden and linuxsampler standalone
- Running JACK with the dummy driver
- Disabling intel-pstate governor
- Changing computer - no luck. Happens on my Core i5 notebook and desktop
- Changing soundcard - no luck. Onboard sound, Behringer 202, Focusrite Scarlett 2i2

The click can be recorded with Audacity, with a JACK-connection from Qtractor/Rosegarden/linuxsampler to Audacity. It looks like a little DC-offset, maybe a negative one in the beginning of the played note. I made screenshots.

A bad note and a good note: http://www.marzen.de/tmp/click.jpg
Another bad note with the visible DC-offset: http://www.marzen.de/tmp/click2.jpg

Any ideas how to get rid of the click?
suedwestlicht
Newbie
 
Posts: 3
Joined: Sat Jun 02, 2012 7:16 pm

Re: Clicky noise woes

Postby suedwestlicht » Thu Jun 26, 2014 7:45 pm

I wrote it to the developers' mailing list.

I tested some more. The sfz-file begins with:

<group>
seq_length=2
ampeg_decay=37
ampeg_sustain=0.001
ampeg_release=0.4
loop_mode=loop_continuous
<region>
sample=1_E_a.wav
lokey=0 hikey=28
[...]

I noticed that if I set seq_length=1 the clicks don't happen.

The clicks only happen when
- seq_length=2
- the same note gets play twice, so that it cycles through the 2 samples
suedwestlicht
Newbie
 
Posts: 3
Joined: Sat Jun 02, 2012 7:16 pm


Return to General LinuxSampler Discussion

Who is online

Users browsing this forum: No registered users and 2 guests